cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 7
Report Inappropriate Content
Message 1 of 4

Query returns 36 results but triggers 0 deployments

I've starting trying to use Rogue System Detection as a more effective way of deploying agents in my ePO 4.5. I setup a query which looks for rogue systems which are part of our domain and detected within the last hour, then an agent deployment is triggered.

If I run the query manually I get 36 results, but when it runs as part of the scheduled hourly task the log says the query completed but then says it is deploying the McAfee agent to 0 systems.

All 36 are reporting the issue as being Alien Agent (we had to reinstall ePO without the previous keys, so they're probably left overs) and the deployment task has been set to overwrite any existing installation.

Why am I not seeing 36 attempted deployments?

3 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 4

Re: Query returns 36 results but triggers 0 deployments

A RSD automatic response should not be based off a query rather you should base it off an RSD Detection event.

You should already have a default RSD response called "RSD: Query New Rogue Detection". Simply edit this response and add your filter criteria to the "Filter" tab. You should not have to add a filter for the time because this response will trigger in the event of an RSD detection (so it should always be within a few minutes of the detection). If you wish to push the agents at a specific time (not tied to the RSD detection event) then set the RSD response action to "add to system tree" rather than "push agent". Then you can automate a query that pushes the agent to unmanaged machines or to machines in a specific group however you like.

Highlighted
Level 7
Report Inappropriate Content
Message 3 of 4

Re: Query returns 36 results but triggers 0 deployments

Can't delete so ignore

Premature response on 29/12/09 06:18:19 CST
Highlighted
Level 7
Report Inappropriate Content
Message 4 of 4

Re: Query returns 36 results but triggers 0 deployments

After a wander through the documentation I tracked this down under Automation. That appears to have done the trick, thanks.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community