cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
sidhinks
Level 8
Report Inappropriate Content
Message 1 of 9

Product deployment over internet failing - Agent Handler giving error

Hi,

We have a small setup with Single McAfee EPO server and internet facing agent handler

We are running EPO on 5.9.1

Product deployment works fine when clients are inside the Network

But when the clients are remote and connected via internet, deployment fails

below is some log info from the agent handler Server <> log

 

0201027095959 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={c3db6e54-185c-11eb-10c2-abe3b50004e6}
20201027100001 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100001 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b4e41482-185c-11eb-0bb3-43e0cf009ce2}
20201027100001 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100001 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b4b2ee70-185c-11eb-2382-c5d4ffe49338}
20201027100002 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100002 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b4e41482-185c-11eb-0bb3-43e0cf009ce2}
20201027100003 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b6118a38-185c-11eb-1782-47e04500a0e2}
20201027100003 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5daa8a6-185c-11eb-2936-b3e15c000ce4}
20201027100003 I #04000 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04000 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b6118a38-185c-11eb-1782-47e04500a0e2}
20201027100003 I #03916 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #03916 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5b002ae-185c-11eb-3865-33e25d008ce4}
20201027100003 I #04012 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04012 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5e3d8fe-185c-11eb-2326-4bded600a4e0}
20201027100003 I #04016 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04016 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5c536d8-185c-11eb-3a0e-37e46f0090e6}
20201027100003 I #04008 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04008 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5f4c916-185c-11eb-048c-d7de2a0030e1}
20201027100003 I #04008 MOD_EPOREPO Received request, uri=/Software/SiteStat.xml, remoteIP=x.x.x.x
20201027100003 E #04008 MOD_EPOREPO mod_eporepo.cpp(301): Server had an error during initialization, cannot serve request. URI=/Software/SiteStat.xml?hash={b5dc7064-185c-11eb-03c6-1bde630074e0}

 

I have tried reinstalling agent handler but it didnt work perfectly

8 Replies
cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 9

Re: Product deployment over internet failing - Agent Handler giving error

This error would prevent any system in network or out of network from getting updates - Server had an error during initialization.  The server needs a restart, then test to see if things work.  Also, are you using run client task now for external deployments or an assigned client task?  Run client task now will not work unless you have dlx brokers set up and clients are connected to dxl.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

sidhinks
Level 8
Report Inappropriate Content
Message 3 of 9

Re: Product deployment over internet failing - Agent Handler giving error

thanks for the information cdinet

Deployment works fine for clients inside the network

I have tested by installing the agent on clients which are external and the automatic deployment was not working on those clients. But as soon as I connect VPN, deployment task runs.

i will restart the server and will update you the status

 

thanks

 

 

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 9

Re: Product deployment over internet failing - Agent Handler giving error

You probably need to set up an agent handler in the dmz with a published dns name/IP so clients can reach it without vpn.  They won't be able to reach an internal server otherwise without vpn.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

sidhinks
Level 8
Report Inappropriate Content
Message 5 of 9

Re: Product deployment over internet failing - Agent Handler giving error

I am sorry that I didnt mention that earlier

We are using the agent handler to server the clients who are external

So the AH is setup in DMZ only

 

thanks

Blekk
Level 9
Report Inappropriate Content
Message 6 of 9

Re: Product deployment over internet failing - Agent Handler giving error

Hello

 
Are the ports configured on the AH in the DMZ ? 

Is the client viewable on the Agent Handler when you are on the internet ? please trigger an update from the client to the agent handler (collect and send props ) and check the ports on the firewall. 

https://kc.mcafee.com/corporate/index?page=content&id=KB66797

 

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 9

Re: Product deployment over internet failing - Agent Handler giving error

Is the epo server enabled in the agent repository policy?  On the agent handler, is the db\repocache directory populated with content?  The ah requires ports 8443, 8444 and 443 to be open to epo and no content filtering for the ah to pull content from the epo server.  The server log on ah would show if it is failing to pull content. 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

sidhinks
Level 8
Report Inappropriate Content
Message 8 of 9

Re: Product deployment over internet failing - Agent Handler giving error

Sorry for the late reply

 

Is the epo server enabled in the agent repository policy?  - Yes it is enabled and I have machines that are utilizing the AH for updates but these are located inside the network

On the agent handler, is the db\repocache directory populated with content?  : I will check and and update today itself

The ah requires ports 8443, 8444 and 443 to be open to epo and no content filtering for the ah to pull content from the epo server. : Ports are open and I was able to work without issues for last couple of years.

The server log on ah would show if it is failing to pull content. : I do not see it is failing to pull content

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 9

Re: Product deployment over internet failing - Agent Handler giving error

Go through this document to see if you can find what the error is showing.

https://community.mcafee.com/t5/ePolicy-Orchestrator-ePO/SOLVED-HOW-TO-TROUBLESHOOT-CLIENT-UPDATE-DE...

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community