cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 7

NaInet library returned code == -9

Hi All,

Previously i had installed epo agent on a windows 7 machine without any problem.

But after some time, when i reopen back the epo server, i noticed that all of the agents are showing an outdated last communication date.

When i check on the client machine, the installed agents shows that it failed to connect to the ePO Server in the Agent Status Monitor.

However, when i tried to wake up the agent from the server, it was successfully executed without any error.

Below are the logs taken from the agents.

2017-03-08 16:53:18.085E#6888ServiceMgrError trace:
2017-03-08 16:53:18.085E#6888ServiceMgr  Not persisting SAHU_SERVER stat data. It is either invalid or not running currently
2017-03-08 16:53:37.962E#6580imsiteError trace:
2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source=Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Common Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
2017-03-08 16:53:37.962E#6580imsite  NaInet library returned code == -9
2017-03-08 16:53:37.962E#6580imsiteError trace:
2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source=Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Common Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
2017-03-08 16:53:37.962E#6580imsite  NaInet library returned code == -9
2017-03-08 16:53:37.962E#6580imsiteError trace:
2017-03-08 16:53:37.962E#6580imsite [uploadFile,,/spipe/pkg?AgentGuid={72C80A8B-5241-4B46-A7B7-DB7DC4F6AE7B}&Source=Agent_3.0.0,pkg00131334368117260000_4016888937.spkg,C:\ProgramData\McAfee\Common Framework\Unpack,C:\ProgramData\McAfee\Common Framework\Unpack\pkg00131334368128100000_1721308088.spkg]->
2017-03-08 16:53:37.963E#6580imsite  The naInet library returned an error. [Parent error: NaInet library returned code == -9]
2017-03-08 16:53:42.969e#6580AgentAgent failed to communicate with ePO Server
2017-03-08 16:53:48.154E#6580imsiteError trace:
6 Replies
Troja
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 7

Re: NaInet library returned code == -9

Hello,

take a look at this Knowledgebase Article. There are all NaInet library return codes explained.

McAfee Corporate KB - The naInet library returned an error. [Parent error: NaInet library returned c...

Hope this helps,

Cheers

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 7

Re: NaInet library returned code == -9

Hi Thorsten,

Thanks for the input, understand that this returned code == -9 stands for Connection to remote server failed.

But is there anyway or perhaps logs can pinpoint the exact issue that causes the connection failed?

Best Regards,

Wai Kit

Troja
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 7

Re: NaInet library returned code == -9

Yes,

you are right. You may take a look at the application Servier log and Apache Log in EPO to see what´s going wrong.

Cheers

Former Member
Not applicable
Report Inappropriate Content
Message 5 of 7

Re: NaInet library returned code == -9

Hi Thorsten,

Still no luck to figured out the root causes.

Can you help to have a look on those logs?

Please let me know if you need additional logs


Thanks,

Wai Kit

Troja
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 6 of 7

Re: NaInet library returned code == -9

Hello,

i´m not really shure what the problem is. So, from my point of view i would do the following steps.

First of all a question, do you see the error only on some clients or on any client? Was there any change to the policies or EPO Server?

You may check the following things.

- Agent tries to use a relay server. Deactivate P2P and Relay Server Settings in the Agent policy. But, the agent will not get the policy, hmmmmm......

- i found a data channel problem in the Agent log. Agent communication failed, result=-2400. You may take a look at this two articles.

McAfee Corporate KB - Client always shows the System State as Inactive (data channel messages exceed...

McAfee Corporate KB - Client always shows the System State as Inactive (MfeEpe.log: send_activate_ex...

Let´s see if there is any change.

Cheers

Former Member
Not applicable
Report Inappropriate Content
Message 7 of 7

Re: NaInet library returned code == -9

Hi Thorsten,

FYI, all of my clients are having the exact same issue.

As the server is being out of monitor for awhile, i am not able to trace any changes made to the server or the policies. *But i believe no one did any changes*

I tried to search few articles about the error (Agent communication failed, result=-2400), one of the suggested solution is actually change the default agent communication port from 80 to another port number.

But in this case, i already changed the port to 8083 even before the problem occurs.

For those articles you shared, my ePO doesn't have McAfee Drive Encryption (DE) 7.1.x and McAfee Endpoint Encryption for PC (EEPC) 7.0.x installed, so both of the article doesn't seem quite related.

Best Regards,
Wai Kit

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community