cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MohdAfiq
Level 9
Report Inappropriate Content
Message 1 of 9

McAfee Wake Up agent Expired:1

Jump to solution

Hello everyone.

Would like to know why when I tried to wake up mcafee agent at linux server, its appears to be expired :1.

But when i enforce policies, the timestamp changes to current time. meaning the agent and server can communicate.

 

thank you

expired.PNG

1 Solution

Accepted Solutions
MohdAfiq
Level 9
Report Inappropriate Content
Message 8 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

Problem solve. Need to open port in Linux firewall. https://kc.mcafee.com/corporate/index?page=content&id=KB91186

# firewall-cmd --list-all
# sudo firewall-cmd --zone=public --add-port=80/tcp --permanent
# sudo firewall-cmd --zone=public --add-port=8081/tcp --permanent
# sudo firewall-cmd --zone=public --add-port=443/tcp --permanent
# firewall-cmd --reload

View solution in original post

8 Replies
MohdAfiq
Level 9
Report Inappropriate Content
Message 2 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution
 
 
6/2/21 4:42:52 PMWaking up agent centos-mc through Agent Handler XXXXX.XXXXXX.local.
6/2/21 4:42:52 PMWaking up agent centos-mc using DNS name
6/2/21 4:42:52 PMUnable to resolve address of remote system
6/2/21 4:42:52 PMWaking up agent centos-mc using NetBIOS
6/2/21 4:42:52 PMUnable to resolve address of remote system
6/2/21 4:42:52 PMWaking up agent at IP address XX.X.X.XXX
6/2/21 4:42:52 PMUnknown error contacting agent
6/2/21 4:42:52 PMWakeup agent failed
6/2/21 4:43:21 PMExpired. The task will be stopped.
cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

Is port 8081 open to that client?  Can you telnet to it from epo server?  Is it behind firewall or proxy?  I would suggest maybe a wireshark capture to see what happens to the traffic with wakeup attempt.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

MohdAfiq
Level 9
Report Inappropriate Content
Message 4 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

port 8081 is open. linux is located at the same server for windows. 

aguevara
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

It sounds like the Agent handler/ ePO server can not see the actuall machines IP and is failing to contact the "known" IP:

6/2/21 4:42:52 PM Waking up agent centos-mc using DNS name
6/2/21 4:42:52 PM Unable to resolve address of remote system
6/2/21 4:42:52 PM Waking up agent centos-mc using NetBIOS
6/2/21 4:42:52 PM Unable to resolve address of remote system
6/2/21 4:42:52 PM Waking up agent at IP address XX.X.X.XXX
6/2/21 4:42:52 PM Unknown error contacting agent
6/2/21 4:42:52 PM Wakeup agent failed

That behaviour is expected if those machines are behind a NATed network or a VPN , as you say they are on the same network but is the IP above on the same network? does the machine have multiple network adaptors? 

Could you also please try a telnet from the ePO server to that machine on port 8081 and the IP mentioned above?

MohdAfiq
Level 9
Report Inappropriate Content
Message 6 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

Hi. i try to telnet using ip xx.xx.xx.xx8081 and when check var/log/messages this appear. could be ens blocking to telnet and waking up agent?        canno telnet.PNG

aguevara
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

im not sure which log is that, (im not an expert with ENS) but it can certainly be a firewall, try to temporarily disable it and see if it helps? 

MohdAfiq
Level 9
Report Inappropriate Content
Message 8 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

Problem solve. Need to open port in Linux firewall. https://kc.mcafee.com/corporate/index?page=content&id=KB91186

# firewall-cmd --list-all
# sudo firewall-cmd --zone=public --add-port=80/tcp --permanent
# sudo firewall-cmd --zone=public --add-port=8081/tcp --permanent
# sudo firewall-cmd --zone=public --add-port=443/tcp --permanent
# firewall-cmd --reload

View solution in original post

aguevara
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 9

Re: McAfee Wake Up agent Expired:1

Jump to solution

Great, thanks for sharing! 

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community