cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Uthra
Level 10
Report Inappropriate Content
Message 1 of 16

McAfee Agent Error

Getting this error failed to get ma info error code 507 mcafee. pls advice

15 Replies
jsubbura
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 16

Re: McAfee Agent Error

Hi @Uthra ,

Thank you for writing in here.

Kindly help us with the below information.

1) McAfee Agent Version:

2) McAfee EPO version:

3) What is the OS in which you are facing this issue? as well as the OS version?

Can you send us a screenshot of the error which you are seeing?

 

Thank you.

Regards,
Jithendran S
McAfee Employee
Uthra
Level 10
Report Inappropriate Content
Message 3 of 16

Re: McAfee Agent Error

1) McAfee Agent Version: 5.6.2.209

2) McAfee EPO version: 5.10 Update 6

3) What is the OS in which you are facing this issue? as well as the OS version? RHEL 5,6,7

AdithyanT
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 16

Re: McAfee Agent Error

Hi @Uthra,

Thank you for your updates. May I know if the MA version you are using is compatible to the version of RHEL you have deployed?

Can you confirm McAfee Agent is functioning properly? is this error seen behind a functional issue on the machine?

McAfee Agent and it's supported OS details are given in the below KBA:

https://kc.mcafee.com/corporate/index?page=content&id=KB51573

I sincerely hope this helps!

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Thanks and regards,
Adithyan T
LKS
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 16

Re: McAfee Agent Error

Is this a clean install or upgrade from older version. Are there any AV installed on the machine.

Did you try to completely uninstall and reinstall Agent. Ensure you delete all the remnants, reboot the server before you proceed fresh installation.

Is all the MA services are running. Does this error occurred when you initiate ASCI from client machine.

Did you install AGent with Root account or normal user account if it is a fresh install.

What do you see in macmnsvc log under /var/mcafee/agent/logs folder.

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a Solution" if this reply resolves your query!

Re: McAfee Agent Error

Good morning, I got this error:

C:\Program Files\McAfee\Agent>cmdagent -p
2021-09-27 09:44:29.931 cmdagent(8972.2460) cmdagent.Error: Failed to get ma info, error code <507>.
2021-09-27 09:44:29.931 cmdagent(8972.2460) cmdagent.Error: Get agent mode failed. Operation failed

I can see my Agent service is disabled since 1 week, and I don't know why.. If I try to "start service", my system Win 7 Service pack 6 replies "the service is disabled or it is not associated with any installed device"!

 

I re-installed McAfee Agent 5.6.6.232 to no avail..

 

aguevara
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 16

Re: McAfee Agent Error

we have resolved similar errors on 5.7.x 

could you please try that version?

Re: McAfee Agent Error

thank you, but I can't try this version..

What reason could there be for Agent service's disabling ..? Some installation?

Why prevents the system me to re-start the "McAfee Agent Common services" and McAfee Agent Service?

 

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 16

Re: McAfee Agent Error

We would need logs to find why it is getting disabled - is self protection enabled?  Is the service itself set to disabled or is it just crashing?  Please open a ticket with McAfee.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: McAfee Agent Error

Thank you for your answer.

It was suggested to me to open a new topic, for this particular issue in Agent service.. but I don't know how!

A few months ago I set up a policy, for some tests on my McAfee Agent, for self-protection non enabled!

The Agent service continued to work until last week: now  I don't know whether it was disabled or it "crashed". .  What does it mean "crashed"?

I need to know all possible reasons..

Thanks. Marco.

 

 

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community