cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Linux (RHEL 7) Agent not responding

Jump to solution

Linux agent 5.6.5 and has ENS modules loaded, stopped reporting to the ePO.

service cma status

McAfee agent service is not running.
McAfee common services is not running.
McAfee compat service is not running.

./cmdagent -i
Failed to get ma info, error code <507>

In the compatsvc_hostname.log file: 

2020-09-04 15:00:08.271 (18125.18125) compatservice.Error: failed to create compatability service context, can't start the se rvice.
2020-09-04 15:00:08.271 (18125.18125) macompatsvc.Error: Failed to create compat service.
2020-09-04 15:30:08.157 (20631.20631) macompatsvc.Info: Starting macompatsvc
2020-09-04 15:30:08.159 (20631.20631) cma.Info: compat service context creation failed, error = <215>.

macmnsvc_hostname.log
2020-09-04 12:00:02.212 (15698.15698) macmnsvc.Error: common services create Failed(1)

masvc_hostname.log
2020-09-04 12:00:02.205 (15696.15696) masvc.Error: io service create Failed(1)

Need to figure out how to get it running again.

 

 

2 Solutions

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

Linux /opt/McAfee/agent/scripts/uninstall.sh
You can also use below commands to remove individual packages.
rpm -e MFEdx
rpm -e MFEcma
rpm -e MFErt
For ENS
Navigate to the directory.
cd /opt/McAfee/ens/tp/scripts
Execute the command.
./uninstall-mfetp.sh
Type yes, when prompted.

You may have to do the same for the other modules.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 13 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

Does epo show the agent communicating properly?  If so, use a client task, not a run client task now or anything else, but an assigned client task to install the threat prevention modules.  

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

16 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

Are you able to restart MA service #: service ma restart?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

If restarting the agent via the command Hem gave you fails, I would suggest removing the agent completely, make sure all remnants are gone, then reinstall to see if that resolves.  KB75550

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted

Re: Linux (RHEL 7) Agent not responding

Jump to solution

[root@hostname]# rpm -e MFEcma
error: Failed dependencies:
MFEcma is needed by (installed) MFEdx-6.0.0-218.x86_64
MFEcma(x86-64) >= 5.6.2-209 is needed by (installed) McAfeeRt-10.6.7-117.x86_64
MFEcma(x86-64) >= 5.6.2-209 is needed by (installed) McAfeeESP-10.6.7-117.x86_64
MFEcma(x86-64) >= 5.6.2-209 is needed by (installed) McAfeeFW-10.6.7-113.x86_64
MFEcma(x86-64) >= 5.6.2-209 is needed by (installed) McAfeeTP-10.6.7-118.x86_64

 

[root@hostname]# rpm -e MFEcma -nodeps -noscripts
rpm: -nodeps: unknown option
[root@hostname]# rpm -e MFErt -nodeps -noscripts
rpm: -nodeps: unknown option

Article does not tell me how to remove other modules installed.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

Linux /opt/McAfee/agent/scripts/uninstall.sh
You can also use below commands to remove individual packages.
rpm -e MFEdx
rpm -e MFEcma
rpm -e MFErt
For ENS
Navigate to the directory.
cd /opt/McAfee/ens/tp/scripts
Execute the command.
./uninstall-mfetp.sh
Type yes, when prompted.

You may have to do the same for the other modules.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

View solution in original post

Highlighted

Re: Linux (RHEL 7) Agent not responding

Jump to solution

I have loaded the new agent and the ENS modules were also reloaded; however now when I try and communicate with the client from the ePO server it fails.  I have made sure I have selinux disabled and the firewall disabled.  

From the ePO server, I can ping the client via host name and the client communicates with the ePO server getting policies, but when I try and push an updated client, 5.6.5.165 it fail to communicate with the client.  

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

What specific errors are you getting in the masvc log for communication failures?  How are you upgrading it - via deploy agent, or a client task to install higher version?  

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 17

Re: Linux (RHEL 7) Agent not responding

Jump to solution

One more question - when you reinstalled ENS, did you do it via epo task or use standalone version to install locally?  If standalone, ENS install reinstalls the agent in unmanaged mode.  You would not see any asci attempt in masvc log if that were the case.

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted

Re: Linux (RHEL 7) Agent not responding

Jump to solution

I'm seeing a "network error was 10061" in the server_hostname.log file.

 

Highlighted

Re: Linux (RHEL 7) Agent not responding

Jump to solution

I think ENS reinstalled as a stand alone.  

So do I remove everything again and start all over?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community