cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
nashcoop
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 21

Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

I upgraded EPO 5.9.1 to 5.10 and now when I log into EPO I get the error below, and no system objects or data are appearing.  I found this link which explains why it's happened, but it doesn't provide a fix: https://community.mcafee.com/t5/ePolicy-Orchestrator/DB-column-quot-OSServicePackVer-quot-disappeare...

Is this a SQL issue that I need to have a SQL admin fix, or is there a KB out there that describes how to fix it?

 

OSServicePackVer.jpg

Labels (1)
1 Solution

Accepted Solutions
nashcoop
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 20 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

I had to remove a replace all McAfee Move extensions in order to fix the issue.

View solution in original post

20 Replies
LKS
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

Hi nashcoop,

Have you installed Cumulative update 4 after upgrading from ePO 5.9 to EPO 5.10. If not, please download from McAfee product download site, install and then check.

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a soultion" if this reply resolves your query!

nashcoop
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

I installed version 5.10 with a release date of July 24, 2019.  The notes say it is ePO 5.10 refresh 4. When I log into EPO it shows Build 2428.

LKS
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

The installer file does not come with update 4. You have to installed separately on top of ePO 5.10. Please download from product download site, install and then check.

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a soultion" if this reply resolves your query!

nashcoop
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 5 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

This one?update 4.jpg

LKS
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

Yes..

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a soultion" if this reply resolves your query!

nashcoop
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

I installed that update and it did not fix the problem.  When I log into EPO I get the same error, and it shows Build 2428, Update Installed: Update 4 (2.0.0.454)

LKS
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 8 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

Could you please show me the completely screenshot of the error which you get in ePO console screen. Also what do you see in Orion log. The error seems like one of the point product column still looking for old column name in the database. 

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a soultion" if this reply resolves your query!

Former Member
Not applicable
Report Inappropriate Content
Message 9 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

Hello,

I would like to request you to please take backup of the ePO and ePO database backup.

https://kc.mcafee.com/corporate/index?page=content&id=KB52126

and execute the below query:

select [EPOLeafNode].[LastUpdate], [EPOLeafNode].[NodeName], [EPOLeafNode].[AutoID] from [EPOLeafNode] left join [EPOComputerProperties] on [EPOLeafNode].[AutoID] = [EPOComputerProperties].[ParentID] where ( ( [EPOComputerProperties].[OSCsdVersion] is null or ltrim( rtrim( [EPOComputerProperties].[OSCsdVersion] ) ) = '' ) or ( not ( [EPOComputerProperties].[OSCsdVersion] is null or ltrim( rtrim( [EPOComputerProperties].[OSCsdVersion] ) ) = '' ) ) ) order by [EPOLeafNode].[LastUpdate] asc

If still this is not getting resolved please open a new service request.

Please make sure that you are taking backup of the ePO server and ePO database before executing the above query.

ePO and ePO database backup is mandatory and recommended before making any changes.

Was my reply helpful?

If you find this post useful, please give it a Kudos! Also, please don't forget to select "Accept as a soultion" if this reply resolves your query!

cdinet
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 10 of 21

Re: Invalid column name 'OSServicePackVer'. after upgrading from 5.9.1. to 5.10

Jump to solution

Are there any customizations to the system tree, such as adding an os version column or any other?  If you set the columns back to default, does issue go away?  Does it occur for all users, or some?  Are you using Active Response?

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community