cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Epo can not get the updates anymore

Hi people,

Since a week i have to check in packages manually again.

It seem to be stuck on checking in package.

Updating seems to be fine, but after that it goes wrong.

So i stop de services from mcafee and restart em again and again till i manually checked in the latest dat files.

Anyone had this experience or have an idea why this is happening?

We run have a Epo 4.5 server.

Thanks for the help.

24 Replies
Highlighted
Level 14
Report Inappropriate Content
Message 2 of 25

Re: Epo can not get the updates anymore

Hello,

if I understood you correctly you have problem with the Update Mastee Repository server task (pull task), not checking in the daily DATs and engine into the master repository when run.

as far as I know if the license period of ePO 4.5 expires, the pull task stops working. Or you might have an evaluation license for ePo 4.5 which has expired.

For accurate error description look into epoapsrv.log in folder C:\Program Files\McAfee\ePolicy Orchestrator\DB\Logs at the time the pull task is run.

Attila

Highlighted

Re: Epo can not get the updates anymore

ok here is a part of that log

20100219160707 I #4160 SiteMgr  GeneralInetRequestThreadProc: Downloading /reportservice.asmx
20100219160707 I #4160 SIM_InetMgr Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\nai7E.tmp\00000000, RemoteDir=
20100219160707 I #4160 naInet   Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx
20100219160707 I #4160 naInet   Trying to download using Microsoft WinInet library
20100219160707 I #4160 naInet   Conneting to Proxy Server 139.2.3.1:80 using INTERNET_OPEN_TYPE_PROXY
20100219160707 I #4160 naInet   No resume download needed, calling InternetOpenUrl
20100219160707 I #4160 NAINET   Resolving name 139.2.3.1 to address
20100219160707 I #4160 NAINET   Name resolved to 139.2.3.1
20100219160708 I #4160 naInet   Downloading a file of total size: 8030, content-length: 8030
20100219160708 I #4160 naInet   Downloaded 8030 bytes this time
20100219160708 I #4160 naInet   Downloaded 0 bytes this time
20100219160708 I #4160 SIM_InetMgr Downloaded file reportservice.asmx successfully in session 1
20100219160708 I #4160 naInet   HTTP Session closed
20100219160708 I #4160 naInet   ------------------------------------------------------------
20100219160708 I #4160 SIM_InetMgr Session 1 ended, result=1
20100219160708 I #4160 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100219160708 x #4160 SiteMgr  SiteMgr main control final release...
20100219160709 I #4160 SiteMgrWrap Created instance of Site Manager
20100219160709 I #4160 SiteMgr  SetEPOMode: SiteMgr enter ePO mode, server=SHBEPO01, port=443, EPOUser=, Password=********
20100219160709 I #4160 SiteMgr  DALInit: Connected to DAL successful
20100219160709 I #4160 SiteMgr  SetEPOMode: Set ePO mode successful
20100219160709 I #4160 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread started
20100219160709 I #4160 SIM_InetMgr Starting download session for url myavert.avertlabs.com:8801
20100219160709 I #4160 naInet   HTTP Session initialized
20100219160709 I #4160 naInet   Connecting to HTTP Server using Microsoft WinInet
20100219160709 I #4160 naInet   Trying to connect to Proxy Server 139.2.3.1:80 using INTERNET_OPEN_TYPE_PROXY
20100219160709 I #4160 naInet   Connected to Server: myavert.avertlabs.com on Port: 8801 using WinInet
20100219160709 I #4160 SIM_InetMgr Started download session 1 for site myavert.avertlabs.com:8801
20100219160709 I #4160 SiteMgr  GeneralInetRequestThreadProc: Downloading /reportservice.asmx
20100219160709 I #4160 SIM_InetMgr Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\nai84.tmp\00000000, RemoteDir=
20100219160709 I #4160 naInet   Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx
20100219160709 I #4160 naInet   Trying to download using Microsoft WinInet library
20100219160709 I #4160 naInet   Conneting to Proxy Server 139.2.3.1:80 using INTERNET_OPEN_TYPE_PROXY
20100219160709 I #4160 naInet   No resume download needed, calling InternetOpenUrl
20100219160709 I #4160 naInet   Downloading a file of total size: 965, content-length: 965
20100219160709 I #4160 naInet   Downloaded 965 bytes this time
20100219160709 I #4160 naInet   Downloaded 0 bytes this time
20100219160709 I #4160 SIM_InetMgr Downloaded file reportservice.asmx successfully in session 1
20100219160709 I #4160 naInet   HTTP Session closed
20100219160709 I #4160 naInet   ------------------------------------------------------------
20100219160709 I #4160 SIM_InetMgr Session 1 ended, result=1
20100219160709 I #4160 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100219160709 x #4160 SiteMgr  SiteMgr main control final release...
20100219160709 I #4160 SiteMgrWrap Created instance of Site Manager
20100219160709 I #4160 SiteMgr  SetEPOMode: SiteMgr enter ePO mode, server=SHBEPO01, port=443, EPOUser=, Password=********
20100219160709 I #4160 SiteMgr  DALInit: Connected to DAL successful
20100219160709 I #4160 SiteMgr  SetEPOMode: Set ePO mode successful
20100219160709 I #4160 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread started
20100219160709 I #4160 SIM_InetMgr Starting download session for url myavert.avertlabs.com:8801
20100219160709 I #4160 naInet   HTTP Session initialized
20100219160709 I #4160 naInet   Connecting to HTTP Server using Microsoft WinInet
20100219160709 I #4160 naInet   Trying to connect to Proxy Server 139.2.3.1:80 using INTERNET_OPEN_TYPE_PROXY
20100219160709 I #4160 naInet   Connected to Server: myavert.avertlabs.com on Port: 8801 using WinInet
20100219160709 I #4160 SIM_InetMgr Started download session 1 for site myavert.avertlabs.com:8801
20100219160709 I #4160 SiteMgr  GeneralInetRequestThreadProc: Downloading /reportservice.asmx
20100219160709 I #4160 SIM_InetMgr Downloading file reportservice.asmx from session 1, LocalDir=C:\WINDOWS\TEMP\nai8A.tmp\00000000, RemoteDir=
20100219160709 I #4160 naInet   Open URL: http://myavert.avertlabs.com:8801/reportservice.asmx
20100219160709 I #4160 naInet   Trying to download using Microsoft WinInet library
20100219160709 I #4160 naInet   Conneting to Proxy Server 139.2.3.1:80 using INTERNET_OPEN_TYPE_PROXY
20100219160709 I #4160 naInet   No resume download needed, calling InternetOpenUrl
20100219160710 I #4160 naInet   Downloading a file of total size: 973, content-length: 973
20100219160710 I #4160 naInet   Downloaded 973 bytes this time
20100219160710 I #4160 naInet   Downloaded 0 bytes this time
20100219160710 I #4160 SIM_InetMgr Downloaded file reportservice.asmx successfully in session 1
20100219160710 I #4160 naInet   HTTP Session closed
20100219160710 I #4160 naInet   ------------------------------------------------------------
20100219160710 I #4160 SIM_InetMgr Session 1 ended, result=1
20100219160710 I #4160 SiteMgr  GeneralInetRequestThreadProc: GeneralInetRequest thread ended
20100219160710 x #4160 SiteMgr  SiteMgr main control final release...

Highlighted
Level 14
Report Inappropriate Content
Message 4 of 25

Re: Epo can not get the updates anymore

This is not the section I had in mind. Look for these kinds of entries:

20100220235946 I #1748 SiteMgrWrap Created instance of Site Manager
20100220235946 I #1748 SiteMgr  SetEPOMode: SiteMgr enter ePO mode, server=MOLSZHBNAIEPOT, port=8443, EPOUser=, Password=********
20100220235946 I #1748 SiteMgr  DALInit: Connected to DAL successful
20100220235946 I #1748 SiteMgr  SetEPOMode: Set ePO mode successful
20100220235946 I #1748 SiteMgr  MirrorThreadProc: Mirror thread started
20100220235946 I #1748 SIM_InetMgr Starting download session for site McAfeeHttp
20100220235946 I #1748 naInet   HTTP Session initialized
20100220235946 I #1748 naInet   Connecting to HTTP Server using Microsoft WinInet
20100220235946 I #1748 naInet   Trying to connect to Real Server update.nai.com using INTERNET_OPEN_TYPE_PRECONFIG
20100220235946 I #1748 naInet   Connected to Server: update.nai.com on Port: 80 using WinInet
20100220235946 I #1748 SIM_InetMgr Started download session 1 for site McAfeeHttp
20100220235946 I #1748 SiteMgr  MirrorThreadProc: Downloading file catalog.z from McAfeeHttp

etc.etc.

You should have section(s) like the above in the same log. Please find them and look for error messages.

Highlighted

Re: Epo can not get the updates anymore

I dont think we have a problem with the internet connection with downloading.

When i try this manually i get the message when i check in the package.. site in use.....

Now i removed the old dat-file restarted the services of mcafee.. and i can check this in again.. (after a few more restarts of mcafee services)

So it doesnt check in easely as it should be.

The checkin goes slow unlike normal

I only notice when you try to do this manually he always gives a message that the site is in use or is still busy copiing.

hopefully this helps more to understand this problem.

thank you again for  your time.

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 6 of 25

Re: Epo can not get the updates anymore

Hi there,

     Do you have any agent handlers configured on this server? If yes, suggest checking if all of them are accessible from the ePO server - the reason being if you have an agent handler that is not currently accessible (could be having connectivity problem?) then when ePO sends a notification to such a handler, it would not timeout. This would cause the package check in to fail.

Let me know if this is the case...

Regards

Sailendra

Highlighted
Level 14
Report Inappropriate Content
Message 7 of 25

Re: Epo can not get the updates anymore

Eurobuger,

actually I did not imply you have trouble with your internet connection, justwanted to see the relevant section in the log file, that applies to pull task run result. What you showed here applied to the AvertAlert query.

Could you locate the section that I have referred to, again?

Thank you.

Attila

Highlighted

Re: Epo can not get the updates anymore

I just put in the whole log in it.

Just can not find any weird things.

Let me know if i overlooked something.

again thanks.

Highlighted
Level 14
Report Inappropriate Content
Message 9 of 25

Re: Epo can not get the updates anymore

Hello,

at the beginning of the log, I seem to have found the end of a potential pull task. Following this to the end I noticed this:

20100223010318 I #2320 SiteMgr  CheckInThreadProc: Check in thread started
20100223010318 e #2320 SiteMgr  CheckInThreadProc: Site ePO_shbepo01 is currently in use, abort...

As if checking in failing due to something keeping master repo in use. Please check if any other server task is run at the time the pull task (or vice versa).

The other entires all have to do with AvertAlert (which I also wonder why they keep happening throughout the log).

Setting the LogLevel regkey to 8 (I wonder if there is a higher level than this), might cause some more detail to occur in the log. See KB for instructions here: https://kc.mcafee.com/corporate/index?page=content&id=KB56207&actp=search&searchid=1266915304986

Then please rerun the pull task and either examine it or post the copy again.

Attila

Highlighted

Re: Epo can not get the updates anymore

It was already on loglevel8.

Not sure if mcafee supports loglevel beyond loglevel8.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community