cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Duplicate Machine Names after ENS Upgrade to 10.7

I have upgrade all workstations in our estate from ENS 10.6.1 to 10.7 using a tag and applied client task method, but I have been left with 1 server and numerous workstations that are showing duplicate machine names. When one is selected both names select automatically. On the server I have deleted the presence in ePO, logged onto the server and reinstalled the agent (5.6.1.308) but the same issue occurs. I have followed KB93129 and rebooted the ePO server and checked the registry entries under HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Network Associates\ePolicy Orchestrator\Application Plugins are not duplicated. This is as well as lots of other machines not upgrading any/some of their ENS components with different failures in the logs (Point Product being a common one) I've tried to 'run client task' for individual components as well as assigning client tasks with varying success. Using ePO 5.9.1
10 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

Hello @idsanalysts 

Thanks for your post.

Please try to select use default columns in system tree and see whether you are still seeing the duplicate machines.

Once don try adding one by one one all the columns which is there and see when the duplicate machines are coming up.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

 

Highlighted

Re: Duplicate Machine Names after ENS Upgrade to 10.7

Hi - thanks for that.

The duplicates reappear when the ATP (Endpoint Security Threat Intelligence) column is added.

 

Highlighted

Re: Duplicate Machine Names after ENS Upgrade to 10.7

See attached registry snip

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

Hello @idsanalysts 

Thanks for your post.

We have seen this type of issues in post where this comes after install/upgrade of ENS extensions.

But here I cannot see multiple entries in the Registry.

I would recommend to delete the systems from system tree and see whether they are coming back or not (Most probably they will come back)
If they are coming back please open a new service request with ATP team and explain the issue.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Highlighted

Re: Duplicate Machine Names after ENS Upgrade to 10.7

Hi - I deleted a duplicate machine and it checked back in duplicated again.

 

I'll raise a call to support, thanks

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 7 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

Hello @idsanalysts 

Thanks for your response.

Please keep us posted with the updates.

Was my reply helpful?
If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!

Highlighted
Level 8
Report Inappropriate Content
Message 8 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

I am seeing the same thing. Sometimes there are even 4 machines -- same Agent GUID.  If you select one in the tree, they both get checked, but it says 1 of 2 selected (when searching by Agent GUID)

 

Extensions: 

Platform: 10.7.0.697

Threat Prevention 10.7.0.755

Adaptive Threat Protection 10.7.0.705

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 9 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

This is typically due to a duplicated property somewhere along the line and when you add non-default columns, it would add an additional entry for that property.  It could also be indicative of staging table not processing data like it should.  You can see if that is an issue if the count of that table is very high.

select count (*) from epocomputerpropsstaging

 

Was my reply helpful?
If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Highlighted
Level 8
Report Inappropriate Content
Message 10 of 11

Re: Duplicate Machine Names after ENS Upgrade to 10.7

I ran the query and I got back the number 76. I'm not sure what that number is supposed to represent, but I know I didn't have 76 columns in my tree view.  I set the columns back to Default and now the number is 7 (there are 6 columns). 

 

The issue is now gone. I'm assuming setting the columns back to default did it, but it's very interesting that a machine would appear just fine with 10.6.1, then upgrading to 10.7 would immediately have this issue.  I watched this on several machines. 

 

Thanks for your help!

Pete

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community