Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 7
Report Inappropriate Content
Message 1 of 11

Can't see Agent activity log from ePO !

Hi all,

I eventually managed to add a couple of PCs (Windows XP SP3 up to date in a domain) from our "old" server (Windows 2003 Server) to our "new" one (Windows 2003 ServerSP2 up to date).

Meanwhile I installed a brand new virtual PC and successfully installed the agent and Viruscan.

However, on my 2 PC with a previous version of agent and Virusscan (agent v4.0 and Virusscan v8.5) even though strategies are succesfully applied and agents are communicating properly with the server and vice versa, when I want to check-out the agent activity log from my ePO console, I get a window like that(hereunder the red stripe is properly displayed but when I connect I  simply get the html code and the text) :

McAfee Agent Activity Log

Version [] Computer name [PC_ETU_TEST] ePO server [EPO]

View debug logs: FrameSvc current / previous, NaPrdMgr current / previous
Date and Time

La page XML ne peut pas être affichée

Impossible d'afficher l'entrée XML en utilisant la feuille de style XSL. Corrigez l'erreur, puis cliquez sur le bouton Actualiser ou réessayez ultérieurement.

Défaillance irrémédiable

Sorry this is in french, but it's said that the "XML page couldn't be displayed. Unable to diplay the XML entry using the XSL style sheet. To correct the error, please press the refresh button or try again later.

Permanent failure.".

Obviously, refreshing the browser page, trying later, rebooting the PC and even the...server is useless !

I thought it could be a GUID related issue and deleted it on one of the 2 PC, rebooted, but to no avail...

I even tried to reinstall the agent from both clients using the commande line ( Frminst.exe /REMOVE=AGENT) but unsuccessfully !


Yet, remember that for my brand new test PC on the which I made a "clean" install of the agent and Virusscan, without any previous version installed, it's working properly !

I can access the log from the console !

Not only that, but if i try to access the activity log with the 2 client PC browsers, typing the address on port 8081 it works too !

I've checked-out all the logs, but couldn't find anything relevant, be it on the client or on the server !

I'm really puzzled as this is the only issue I have (for the moment) in my upgrade process (I'm just tesing out the full install on a virtual server and a virtual PC).

Anybody has a clue !?

Thx in advance,


10 Replies
Level 7
Report Inappropriate Content
Message 2 of 11

Re: Can't see Agent activity log from ePO !

Is Internet Explorer up to the latest version and patched on the Server?

Doesn't sound like a backend ePO problem if you can view the logs from different machines.

Level 7
Report Inappropriate Content
Message 3 of 11

Re: Can't see Agent activity log from ePO !

I don't see where you specify what browser you're using.  I used to get style sheet errors with Firefox and the 4.0 agent.  I say "used to" because we've upgraded to the 4.5 agent and the problem is resolved.  I still get "Error loading stylesheet: Parsing an XSLT stylesheet failed" if I try to view a 4.0 agent log remotely in Firefox.

Message was edited by: woodsjw on 3/17/10 8:05:32 AM GMT-08:00
Level 7
Report Inappropriate Content
Message 4 of 11

Re: Can't see Agent activity log from ePO !

Hello Craig and Woodsjw !

First of all, thx for your answer ! 😉

Regarding the browser, I simply use Internet Explorer since I didn't want to take the chance to have any compatibility issue, even though I do know that FireFox is supposed to be compatible !

The I.E version is the lastest one for a Windows 2003 Server :

   - Version : 8.0.6001.18702 with encryption at 128 bits.

Since the ePO site is in the trusted list, apparently, there's no problem related to security settings.

But I acknowldege this kind of message is often related to security settings, but once again, that couldn't explain why one client is accessible and not those with previous versions uninstalled...

This is really the weird part, since the agent activity log of my "virtual test" computer (the one without any previous version of Mc Afee security products) is fully and flawlessly accessible from my server browser/console !

Yet, this is the very same server with the same browser supposed to access the same agent version on all test PC !

I could understand that a browser type or version could be involved if I had the same issue with ALL my client PC, but this is definitely not the case...

I even thought that a missing update could explain for this issue on the client side and updated one of the 2 PCs with SP3 (these are Windows XP) and the latest updates available through Windows Update site, but to no avail again !

Any other idea ?

Thx so much,

Kind regards,


Ce message a été modifié par: Fazer_49 on 18/03/10 02:54:46 CDT
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 11

Re: Can't see Agent activity log from ePO !

The stylesheet in qustion is the one located in the DB folder on the client machine that you're trying to look at.

Logically, the stylesheet must be OK on the affected machines, since you can view the log from different machines - just not the ePO server, is that correct?

I'm wondering if there's an IE setting on the ePO server that's preventing the stylesheet form being loaded... if you install Firefox on the ePO server (just as a test) does that work?

Regards -


Level 7
Report Inappropriate Content
Message 6 of 11

Re: Can't see Agent activity log from ePO !

Hello Joe !

Bingo !

Installing FireFox v3.6 I managed to access the file and diplay it properly in the browser window ! 😉

So, now,  I'll have to figure out which setting(s) is (are) preventing the page from being loaded in I.E8 for the "old" PC initially installed with a previous version !!

But admittedly, even though it works fine with FireFox,  how comes it's working with the "clean" PC and NOT with the 2 other installed with a previous version !!!!

I'm really puzzled by this issue !

It should be an "everything or nothing at all" case, no !?

Anyway, I'll let you know if I can find the proper settings !

Thx so much,


Edit : I think that the problem is linked to the settings used for the security in I.E 8.

         Following the advice of a colleague, I've added one of the 2 PC I.P address in the Intranet Site list (Tools --> Internet Options --> "Security" tab --> Local intranet), and now, I can remotely access the agent log without the display bug !

         I also tried to access one client still managed by the "old" server (the current one with ePO v4.0) from my "new" server browser, and I got
         the same bug !

         Therefore, ePO v4.5 is not involved in the problem, this really has to do with IE 8 !

         I've tried multiple combinations of settings but couldn't find how to remove this bug or simply add I.P address classes like "10.12.0.*" or "10.*"
         to add our... 650 PC in the safe list !

         Any solution would be welcome.

Ce message a été modifié par: Fazer_49 on 18/03/10 07:55:41 CDT
Level 7
Report Inappropriate Content
Message 7 of 11

Re: Can't see Agent activity log from ePO !

Hey Frazer,

  Did you got the solution ?

Message was edited by: enggaamir on 30/1/11 12:08:02 PM GST
Level 7
Report Inappropriate Content
Message 8 of 11

Re: Can't see Agent activity log from ePO !

Hi Joe,

  I am having simillar issue after upgarding EPO 4.5 P3 from EPO 4.5. Please help me if you have the solution.

  When i add the IP of the sytem in trusted list it works.



Re: Can't see Agent activity log from Client !

Hi Everyone,

I just implemented McAfee EPO 4.5 but I cannot view the computers that are installed with Mcafee Agent logs via Port 8081 - http://computername:8081
I can telnet to the computer via port 8081 so the port is open.

Can anyone advise me any step that I might have missed out?

Level 7
Report Inappropriate Content
Message 10 of 11

Re: Can't see Agent activity log from Client !


Go to your McAfee Agent Policy and under General see if this box checked or not "Accept connections only from the ePO server" if its checked, uncheck this save and then try if you can view "agent log" through your ePO console.

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community