cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Former Member
Not applicable
Report Inappropriate Content
Message 1 of 4

Can't login to ePO / SQL & Security errors

Jump to solution

Greetings all,

  Having a bit of trouble with my ePO and thought this may be the best place to start.  Will lay out the background before the problem because it may help for responders.

  I am active duty military working at a small unit in the middle of nowhere.  We have a legacy network which is required to provide critical functions.  Because it is legacy and not our main network, there are very few users and only a handful of servers on it.  HBSS/ePO are on it because it is a requirement for all DoD Networks, legacy or not.  I am an electronics tech with a couple IT certs.  The command determined I was the 'most qualified' to replace the sole HBSS admin.  The civilian HBSS admin resigned because her spouse was military and transferred, but was able to give me a 1 week crash course on the ePO. 

  So there we are.  I've touched it, I've poked it, but primarily tried not to break it.  It sits on a legacy network that provides a critical function, so doing the wrong thing in HBSS/ePO has the potential to break that function.  So I treated it like a firewall for the most part, looking and checking up on it...  But not really digging in or making changes to see what would happen.  After about 60 days sitting in the primary SysAdmin seat, I was recalled back to the antenna field to fill holes there as well, as a few personnel had left.  Electronics Tech sometimes translates to 'everything tech'...  Made evident as 60 days after that I am back in the SysAdmin/HBSS seat which has been vacant the last 2 months.  I was called upon again because some patches are due.  And my initial findings...

  Upon reaching the server, "number five" which hosts both the SQL database and ePO, I found that it was still locked out with my user name and password from when I had departed SysAdmin 2 months prior.  So no one has touched it.  "Five" also has RDP disabled and can only be accessed locally, so I am fairly certain nothing has happened user/admin wise with 5 since I left.  When I unlocked the system the ePO dashboard was already up, but unresponsive.  There were some other items not responding as well so I decided to do a reboot. 

  After reboot, before logging in there was a "one or more services failed to start....  see event viewer for details" popup.  I logged in, checked the event viewer, and while I didn't find any service errors, I did find numerous "failed audit" errors.  441,000 in the past 9 days...  But no one had logged into the machine in at least 45.  The error (paraphrased) says "The user '' does not have an authorized SQL profile".  The logs wouldn't go back further because of the quantity of errors.  Lower down on the error it specifies that it's server 5 and my login name.  Shouldn't be an issue, it all worked before.  I can also access SQL studio with my login and recieve no errors or challenges.

  Starting the ePO results in about 50 errors in red below the login prompt, and also will not allow me to login.  All I know about SQL is that it's a database.  I don't think anyone here knows SQL well either.  But I'm not entirely sure this is solely a SQL error...  So...  Where to begin troubleshooting?

1 Solution

Accepted Solutions
Former Member
Not applicable
Report Inappropriate Content
Message 3 of 4

Re: Can't login to ePO / SQL & Security errors

Jump to solution

kmcin11, due to the nature of the server, getting a screenshot would be a fairly arduous process.  Understand it would provide the verbatim error and other information I may have left out...  But I believe I have resolved the issue after about 24 hours of banging my head on the keyboard...  And of course, in line with irony, I figure it out right after I ask for help.

Right before they transferred me back to work with the antenna guys again, the HBSS server password policy required me to change my password.  I used the same first 14, but ended with three &&& instead of three ***.  Everything worked well that last week, but it could have possibly been because I remained logged into the server as I was the sole Sys/HBSS admin.

So I overrode the password policy, changed my password back to the old one, conducted a reboot...  All of the SQL user errors are now gone and I can log into the ePO with no issues.  Problem resolved.  What a PITA though.  Will be sure to turn that over to whomever shows up to take the job permenantly. 

View solution in original post

3 Replies
Former Member
Not applicable
Report Inappropriate Content
Message 2 of 4

Re: Can't login to ePO / SQL & Security errors

Jump to solution

Hi Wagnbat,

Please post a screenshot or the text in red here. The final part of the red errors are the most imortant. Usually you won't be able to scroll down the window when you see these errors, so you have to left-click your mouse to capture the red text and drag it down to the bottom of the screen.

We will most likely see what the issue is once you have provided the screenshot.

K

Former Member
Not applicable
Report Inappropriate Content
Message 3 of 4

Re: Can't login to ePO / SQL & Security errors

Jump to solution

kmcin11, due to the nature of the server, getting a screenshot would be a fairly arduous process.  Understand it would provide the verbatim error and other information I may have left out...  But I believe I have resolved the issue after about 24 hours of banging my head on the keyboard...  And of course, in line with irony, I figure it out right after I ask for help.

Right before they transferred me back to work with the antenna guys again, the HBSS server password policy required me to change my password.  I used the same first 14, but ended with three &&& instead of three ***.  Everything worked well that last week, but it could have possibly been because I remained logged into the server as I was the sole Sys/HBSS admin.

So I overrode the password policy, changed my password back to the old one, conducted a reboot...  All of the SQL user errors are now gone and I can log into the ePO with no issues.  Problem resolved.  What a PITA though.  Will be sure to turn that over to whomever shows up to take the job permenantly. 

Former Member
Not applicable
Report Inappropriate Content
Message 4 of 4

Re: Can't login to ePO / SQL & Security errors

Jump to solution

From the desciption of your fix it suggests that the admin password you changed could be hard coded against the Windows services that failed to start

This would mean that the next time the policy forced you to change the password you would be in the same situation again.

services.jpg

Check the account details against all the McAfee and SQL services just to be on the safe side.

Message was edited by: Tristan on 29/03/12 09:06:46 IST
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community