cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 7

Can't deploy an agent to a machine

Jump to solution

Hi,

We have tested the "McAfee Endpoint Security 10.5" product in one of our Windows 10 machines.

It was a full install. Then, we uninstalled the product from the machine and reinstalled McAfee VirusScan 8.8 patch 9 (standalone installer).

When we try to deploy the agent from ePO to this machine, it is returning this error:

"Failed to authenticate with remote system, system error: Access is denied."

I joined the machine again on the domain, manually deleted the McAfee folders, regedit keys, checked the PC time, rebooted the machine and nothing... same error.

The machine is (for now) with VirusScan updating only from internet.

Any idea?

Att,
Vandrey Trindade
1 Solution

Accepted Solutions
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 5 of 7

Re: Can't deploy an agent to a machine

Jump to solution

​,

Hi! I managed to make it work by using ​ message from another post:

"Hmm, you mentioned you deployed from checked in package; what about installed from it?  You can generate a manual installation package by going to System Tree --> New System --> Create and download agent installation package.  Then use that file to do the manual install; that will distribute the ePO server settings, while the one you download directly from McAfee won't have your server settings."

I created a package without embedded credentials and the client machine now appears as "Managed" on ePO!

Maybe is a package problem? (McAfee Agent 5.05)

Thanks!

Att,
Vandrey Trindade

View solution in original post

6 Replies
tao
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 7

Re: Can't deploy an agent to a machine

Jump to solution

Check the access protection log for blocks relating to the install of the McAfee agent.

If this information was helpful or has answered your question, please select Accept as Solution. This will assist other memebers
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 7

Re: Can't deploy an agent to a machine

Jump to solution

You mean on the client?

I'll install VirusScan 8.8 patch 9 again (tried using McAfee product removal to clean thing again...) and check it.

Att,
Vandrey Trindade
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 7

Re: Can't deploy an agent to a machine

Jump to solution

Checked. It's clear. Has nothing in there.

Att,
Vandrey Trindade
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 5 of 7

Re: Can't deploy an agent to a machine

Jump to solution

​,

Hi! I managed to make it work by using ​ message from another post:

"Hmm, you mentioned you deployed from checked in package; what about installed from it?  You can generate a manual installation package by going to System Tree --> New System --> Create and download agent installation package.  Then use that file to do the manual install; that will distribute the ePO server settings, while the one you download directly from McAfee won't have your server settings."

I created a package without embedded credentials and the client machine now appears as "Managed" on ePO!

Maybe is a package problem? (McAfee Agent 5.05)

Thanks!

Att,
Vandrey Trindade
tao
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 6 of 7

Re: Can't deploy an agent to a machine

Jump to solution

Ok, when deploying the agent use the same credentials that are able to actually login to that machine.  Also, check to make sure those credentials have the rights to install on that machine. Even thou the credentials allow for a logon; they may not allow for an install.

If this information was helpful or has answered your question, please select Accept as Solution. This will assist other memebers
vandreytrindade
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 7 of 7

Re: Can't deploy an agent to a machine

Jump to solution

I used the domain admin account. And it was complaining about wrong credentials.

Tried the same agent deploy with the same credentials to my machine and it worked.

Maybe the other product messed up with something on the other machine...

Att,
Vandrey Trindade
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community