Showing results for 
Show  only  | Search instead for 
Did you mean: 
Level 10
Report Inappropriate Content
Message 1 of 3

Agent Deployment tasks don't work


I noticed something weird.

I created a server task that first runs a query "Query_A" that lists all clients without an agent in the epo directory.

Then I add an sub action " Deploy McAfee Agent"

When I execute that task I see in the server Task logs that the query finds some clients without an agent and start to deploy the agents to them
BUT they all expires (why ??? (The subtasks Tab in the task log stays empty))

6/17/11 5:17:25 PM Started: Run Query
6/17/11 5:17:25 PM Completed: Run Query (The query 'Query_A' was run as a scheduled command or part of a scheduled command chain. )
6/17/11 5:17:25 PM Started: Export to File - report
6/17/11 5:17:25 PM Completed: Export to File - report (Export to File (004001a_Sync%26Deploy_TTG_-_Start_Install_Agent_On_%28Query%29) was successful.)
6/17/11 5:17:25 PM Started: Deploying agents to 159 system(s)
6/17/11 5:38:28 PM Completed: 0
6/17/11 5:38:28 PM Failed: 0
6/17/11 5:38:28 PM Expired: 159
6/17/11 5:38:28 PM _004001_Deploy Agent (Query) [TTG-TTG] (Deploy Agents)

But when I run the same query "Query_A" manually, select all the clients from the query out put and apply a "Deploy Agent" task to them via the actions menu it does install the agents as it supposed to do. (ans the subtasks tab of the server task log does show an proper overview)

6/17/11 5:48:19 PM Started: Deploying agents to 159 system(s)
6/17/11 5:51:26 PM Completed: 40
6/17/11 5:51:26 PM Failed: 2
6/17/11 5:51:26 PM Expired: 117
6/17/11 5:51:26 PM Completed: Deploying agents to 159 system(s) (Deploy Agents)

Why does it work manually and not via a server task? (I use the exact same settings/parameters in both deployment tasks)?



2 Replies

Re: Agent Deployment tasks don't work

When you see the "expired" status it usually means that the ePO server cannot reach these computers to deploy the agent.

But when you launch the task I suppose you're launching it through the web interface of your computer but no from the ePO server. First thing you should do is to check details of the deployment so you can see the exact problem with it

Level 10
Report Inappropriate Content
Message 3 of 3

Re: Agent Deployment tasks don't work

I tried launching it from both my computer and the eposerver both with the same results

What other details than the "Server Tesk Log Details" can I check?
following these logs the server doesn't even try to connect to the clients via the server tasks (Subtasks listing stays empty)

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community