Showing results for 
Search instead for 
Did you mean: 

What happened to the Google Search Result icons?

The icon behind each Google search result is gone...... for the last 2 weeks. Uninstall and reinstall did not help. Didn't work on xp, vista, OR Mac Tiger. What's going on?
7 Replies

RE: What happened to the Google Search Result icons?

It may make things worse, it may make things better:
try updating the SiteAdvisor.

RE: What happened to the Google Search Result icons?

By updating, you mean how? Would a new installation not be the latest version of SA?

RE: What happened to the Google Search Result icons?

Not necessarily. When I did the whole uninstall and reinstall thing, I did not get the lastest version of the SiteAdvisor, which I found out when I tried to update the SiteAdvisor (thingy at the top left of the screen).

Oh, and I remember that a couple of hours later saservice(.exe) jumped on my system, I received an informational alert. (You may not receive such an alert if you have not customized informational alerts, I don't know). My guess would be that the alert stated that "it" had been added to the program authorizations of the firewall (probably in different words).

RE: What happened to the Google Search Result icons?

I just downloaded the SA plug in for Firefox. I went to Firefox add-ons and did a "find updates" for all the add-ons. Is this how you did your update? The icons are still not showing up though.

RE: What happened to the Google Search Result icons?

No, I clicked on the plug-in at the top left of my screen, and from there I updated the SiteAdvisor to a new version.

RE: What happened to the Google Search Result icons?

I just experienced something similar, although it seemed that the SiteAdvisor was enabled.

I would suggest disablining and enabling (or enabling, disabling, and enabling), one time or a few times. I'm referring to the SiteAdvisor thingy at the top left corner of the screen.

RE: What happened to the Google Search Result icons?


We received your message reporting no annotations ( = Search result icons) on the google search results page on Vista, XP and Mac Tiger OSes. Thank you for contacting us.

You can download the latest version of SiteAdvisor from or if you already have SiteAdvisor installed on your machine, please follow these steps:-
(i) Click on the black arrow mark in the SiteAdvisor toolbar
(ii) A drop-down menu would appear. On this menu, click on the "Get latest Version" option
(iii) A new IE window spawn with a link to upgrade if one is available

We would need some more information before we could help you out. Please answer the following questions:-

1. Could you please specify the version of SiteAdvisor you are using on which this issue was found prior to update if any. To find this,
(i) Click on the black arrow mark in the SiteAdvisor toolbar
(ii) A drop-down menu would appear. On this menu, click on the "About" option
(iii) In the 'About' dialog box, just above the 'OK' button, 'Version' would be displayed. (e.g.,

2. Could you please specify the google domain on which you performed the search. For example was it on or (- Google Canada). It might be possible that in on of the localised search engines that the annotations ( - Search result icons) are not displayed. We do annonate on most of these localized search engines. But, it is possible that on some of these search engines annotations are not displayed. In that case, this is a bug and we will fix it.

3. Please specify the browser (along with its version) that you used to perform the google search. Currently, SiteAdvisor supports only Internet Explorer (version 6.0 and above) and Firefox (version 1.5 and above) browsers. So, if you were using other browsers like Safari, Netscape Navigator or Opera, no annotations ( - Search result icons) will be displayed by SiteAdvisor.

4. Were you able to consistently reproduce this issue on your machine? Were annotations ( - Search result icons) displayed on other search engines like Yahoo! search (, MSN (, Live( and

5. Do you have the SSL option turned 'off' on your Internet Explorer browser? To check this,
(i) Open Internet Explorer
(ii) Click on Tools (or press Alt+T)
(iii) Click on 'Internet Options'
(iv) Click on the 'Advanced' tab
(v) In the list of options displayed, scroll down to the bottom where the 'Security' options are diplayed. Here check if 'Use SSL 2.0' and 'Use SSL 3.0' are checked (These options would be checked by default).

If these options are unchecked, then check whether SiteAdvisor SSL option is turned on. To check this, please follow the stpes given below:-
(i) Click on the black arrow mark in the SiteAdvisor toolbar
(ii) A drop-down menu would appear. On this menu, click on the "Settings..." option
(iii) Check whether 'Use SSL communications to server' option is checked (This option will be unchecked by default).

If the SSL option of Internet Explorer is unchecked and SiteAdvisor's SSL option is checked, then you will not be able to see any annotations on any search engine (google, yahoo, msn, live, etc.). This is a known issue. This is because Internet explorer has disabled SSL communications and SiteAdvisor is trying use SSL to communicate with our servers. Hence, SiteAdvisor is unable to communicate and search result are not annotated.

To overcome this, we suggest that you turn on SSL in Internet option. Make sure the option is checked. This is good since SSL provides secure communications on the Internet for web browsing, e-mail, instant messaging, etc. Once you turn this feature 'on' by checking the option , close and re-open your browser and perform any search on Google. you should be able to see annotations ( - site advisor ratings)

Also let us know know whether annotations were displayed on page refresh (Hit the F5 key or right click on the page and click on the 'Refresh' option). Please perform another search on google and check if annotations are displayed.

You could also try re-installing, SiteAdvisor. That might solve the problem. For re-installing, please follow these steps:-

1. Uninstall McAfee SiteAdvisor program through "Add or Remove Programs" in Windows "Control Panel".
2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MCPR.exe) - . This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)
3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming
4. Reboot and redownload your McAfee SiteAdvisor from the website (

Once you give us more information we'll get back to you immediately with a solution if possible. Thank you for being a McAfee customer.

Praveen Rajaretnam
Associate Software QA Engineer
McAfee SiteAdvisor Consumer QA

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community