cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
cyberdude
Level 11
Report Inappropriate Content
Message 1 of 12

Webadvisor using in Firefox not working ?.....

hello,

i would like to ask the following;

since Firefox 57 using WebAdvisor i noticed the following;

when i download a file a blue scanning display came up from WA to check the dowload file. using current FF 61.0.1 the display doesn't appear.

using IE11 i don't see this scanning display also........

since FF57 when i open the browser the WA stays grey. when i visit the addon page in FF and disable and enable again the icon is becoming active.

i am using FF  61.0.1 with AdblockPlus and Noscript.

are these still known bugs perhaps ?

there was months back a discussion about this in this topic below;

https://community.mcafee.com/t5/WebAdvisor/After-firefox-update-to-version-57-0-Webadvisor-disabled/...

using  current Windows10 32bit version 1803

mcafee livesafe

11 Replies

Re: Webadvisor using in Firefox not working ?.....

@cyberdude

Please trust McAfee in Noscript and try downloading files. Also Update McAfee and check whether you are able to download files

Regards,
Siva

cyberdude
Level 11
Report Inappropriate Content
Message 3 of 12

Re: Webadvisor using in Firefox not working ?.....

@sivasubramanian

hello siva,

thank you for your reply on my question.

i would like to add Mcafee as trusted in Noscript as you suggested, but i need a little help on that ;

if i open Noscript10  settings page i see 4 different tab pages; general, Per site Permissions, ect.

is it possible that you could add pictures how i can follow up your advice to trust Mcafee in Noscript ?

Edit;

i would like to add the folowing;

i am using FF with AdblockPlus and Noscript.

the WA extension addon itself is working in Firefox.

1. when i open the Firefox browser it is the WA display icon  that stays grey when i visit different webpages. if i go to the addon page in FF and click disable and directly enabale again the WA display icon becomes active visiting the different websites.

2.i can download files. but after downloading a file a blue scanning bar showed up to scan the file after download. that is not appearing since FF57.

WA is installed in IE11.in IE11 i don't see this blue scanning bar also after downloading a file

hope this helps.

Re: Webadvisor using in Firefox not working ?.....

@cyberdude

You can trust the McAfee website in No Script as in screenshot. Check whether it works. If issue persists then please disable NoScript and download the eicar_com.zip from the link Eicar file where McAfee WebAdvisor will block the file from downloading.

No Script.png

 

 

FF blocks the eicar.PNG

Regards
Siva

cyberdude
Level 11
Report Inappropriate Content
Message 5 of 12

Re: Webadvisor using in Firefox not working ?.....

hello Siva,

thank you for your answer.

in FF i have selected the extensions  McAfee Webadvisor and Noscript (default setting)

i went to the eicar page for download and received the window message from webadvisor that the download is dangerous as posted in your answer above.

i have also done the eicar file download with AdblockPlus enabled and the result was that the window message from webadvisor showed the message that the download is dangerous.

that worked fine.

the question i would like to ask;

before Firefox 57 Webadvisor showed a blue scan bar when  a file was downloaded for a few secounds to check that file.

is it that nowadays Webadvisor does a file check in the background and give the window with the message 'that download is dangerous' when the file is considered unsafe ? and is not showing a blue scan bar after a file download for a few seconds anymore  ?

cyberdude
Level 11
Report Inappropriate Content
Message 6 of 12

Re: Webadvisor using in Firefox not working ?.....

@sivasubramanian

hello siva,

i would like to ask the following about the Webadvisor addon;

when i install Livesafe on my computer the WA addon is installed by default in IE11 and Firefox browsers.

it is not installed in the Edge browser at present.

is WA not available for the Edge browser ?

 

 

Re: Webadvisor using in Firefox not working ?.....

@cyberdude

The McAfee WebAdvisor extension for Microsoft’s Edge browser is available in MS store and could be installed following the below steps. 

  1. In Edge, click on the ellipses (3 dots) at the top right corner, and then choose Extensions from the drop-down list
  2. Click Get extensions from the Store
  3. Type McAfee in the Search box at the top right
  4. Because McAfee WebAdvisor may not show in the short list that is displayed, either click on the Search magnifying glass, or hit your Enter key
  5. Click on McAfee WebAdvisor when it displays, typically in the first row of items
  6. Click on Get.
  7. The extension will download and install on Edge.
  8. Click Launch
  9. In the notification that you have a new extension, click Turn it on to enable the new McAfee WebAdvisor extension.

Siddhartha.R                                                                                                                                  

Was my reply helpful? If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

cyberdude
Level 11
Report Inappropriate Content
Message 8 of 12

Re: Webadvisor using in Firefox not working ?.....

@siddharth_r

hello siddhartha,

thank you for your answer.

i have found the WA addon for Edge in the MS store.

i would like to ask one more question regarding Webadvisor in Firefox;

i am using WebAdvisor together with AdblockPlus and Noscript.

normal you will see a WA icon display with the red McAfee logo with a green little bar above when visiting a website.

when i use WA and Noscript only in Firefox WA is showing red Mcafee logo and the green little bar above in the WA icon display.

when i use WA and AdblockPlus only in Firefox WA icon display is staying gray/grey.

although staying gray/grey WA is working; it shows the Woah pages visiting wrong websites or downloading unsafe files to the computer.

when you have WA and AdblockPlus enabled for the first time , WA is still showing the red Mcafee logo and the green bar above visiting different websites.

when you close Firefox completely and restart and visit different websites the WA display icon will stay gray/grey

if you have only WA and AdblockPlus installed/enabled in Firefox do you see the same as i do ?

 

 

 

Re: Webadvisor using in Firefox not working ?.....

@cyberdude

Thank you for the update. I've noticed the similar issue when i attempted to close Firefox completely and restart and visit different websites enabling Ad block plus the WA display icon goes grey. Since you're using both these extension. Please disable both no script and Adblock plus and try to enable no script first and then Adblock plus and update the status.

Siddhartha.R                                                                                                                                              

Was my reply helpful? If this information was helpful in any way or answered your question, will you please select Accept as Solution in my reply and together we can help other members?

Re: Webadvisor using in Firefox not working ?.....

@siddharth_r

hello siddhartha,

thank you for your answer.

i have tried your suggestion to disable AdblockPlus and Noscript. then closed Firefox and after restart i first enabled Noscript and then AdblockPlus the WA display icon is active but when i close Firefox and restart again with these addons the WA display icon is grey.

i have tried the following;

WA + Noscript enabled and after restart WA display icon is active.

WA+ AdblockPlus enanbled and after restart WA display icon is grey.

WA+ AdblockPlus + Noscript enabled and after restart WA display icon is grey.

the problem seems te caused by the addon AdblockPlus.....

does this help you identify the problem perhaps ?

 

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community