cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted

Web search turns itself off

Jump to solution

I just got my computer back after getting infected by something Mcafee didn't catch. I lost everything. Anyway now I have it back and I go to look at the receipt and I get a message in red. Something like be careful safe search is off. Do you want to turn it on after restarting? I didn't turn it off! I've never turned it off!! I want it to be always on. Why does it just turn itself off and how do I keep it always on. I'm freaking out. I'm always running scans that say everything is fine but meanwhile it gets infected. I'm very stressed. The chat doesn't seem to work, and I don't have time to do a chat anyway. I just want to know my computer is safe so I can re add all my files.

1 Solution

Accepted Solutions
McAfee Employee dougk_t3
McAfee Employee
Report Inappropriate Content
Message 12 of 13

Re: Web search turns itself off

Jump to solution

skybird,

Based on your description, the problem you're seeing is simply a reminder; we check with you every few months if you still want SecureSearch turned off. 

If someone has turned off SecureSearch by selecting another search engine e.g. Google, then we would start the process of checking if you still want SecureSearch disabled.

Again, based on your description, it appears that this behaviour is "by design", meaning that there's nothing wrong; there are no technical problems with your McAfee WebAdvisor, or malware on your system.

12 Replies
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 13

Re: Web search turns itself off

Jump to solution

I moved this to Consumer > General Discussions as a better spot for it.

Sorry you had all that trouble but no antivirus is 100% guaranteed.  You have to be extra careful where you surf, what you download and how you deal with spam email, to name just a few risks.

See the last link below for some suggestions on that matter.

Safe Search is a Google Search feature that is off by default.

See Turn SafeSearch on or off - Search Help

To further make searches and online browsing safer, if your McAfee software doesn't already include it I would download and install McAfee WebAdvisor.

It's free of charge and works in Internet Explorer, Firefox and Chrome browsers.

Also when installing anything, always monitor the process carefully as often there are "Optional" extras included which could be dangerous, that it's up to you to refuse.

Peter.gif

Toronto ▪ Canada

Volunteer Moderator - Consumer Products
I CAN'T HELP PRIVATELY - PLEASE POST IN THE FORUMS
Use Advanced Search To Find Answers
How To Submit A False Detection To McAfee
Beta Test McAfee Products For PC & MAC
Anti-Spyware/Malware/Hijacker Tools

Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 3 of 13

Re: Web search turns itself off

Jump to solution

I forgot to mention, it is vital that you always keep your system totally up to date including any parts you may not use, for instance, say you use Firefox as your browser, make sure Internet Explorer updates are always installed.

Re: Web search turns itself off

Jump to solution

I think I meant that webadvisor is turning itself off. Got the name confused. Also I got this warning on a document that was in explorer. (I hate explorer). It wasn't even something that should be online so I don't understand why I was seeing it.

Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 5 of 13

Re: Web search turns itself off

Jump to solution

Many applications access the web behind the scenes and WebAdvisor would warn about that.   There are 2 Explorers, Windows Explorer, which is your internal browser within your system - looking at Computer or Control Panel for example, and Internet Explorer the web browser.

I suggest uninstalling and reinstalling Webadvisor in this instance.  It is listed in your Control Panel > Programs and Features.

Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 6 of 13

Re: Web search turns itself off

Jump to solution

Did that fix it?

Reliable Contributor catdaddy
Reliable Contributor
Report Inappropriate Content
Message 7 of 13

Re: Web search turns itself off

Jump to solution

Moved from General Discussion to McAfee WebAdvisor (formerly SiteAdvisor >Discussions

Cliff
McAfee Volunteer
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 8 of 13

Re: Web search turns itself off

Jump to solution

I forgot to mention that setting WebAdvisor Secure Search "On" restricts your choice of Search Engines from to Yahoo only.

If you want to use Google for instance, you'd need to create a desktop shortcut to it.

Reliable Contributor catdaddy
Reliable Contributor
Report Inappropriate Content
Message 9 of 13

Re: Web search turns itself off

Jump to solution

Could you kindly inform us if you have resolved your issue?

Cliff
McAfee Volunteer

Re: Web search turns itself off

Jump to solution

I've had the same problem for awhile.  It happens about every 2 months.  The exact message is:

   "McAfee Web Advisor
   [Red Title] Secure Search is off - be careful
   Secure Search steers you away from risky sites in your search results.
   Want to stay ahead of the bad guys with extra search protection?
   [check box] Yes, turn Secure Search on after I restart my browser. [Done]"

I check the box and click "Done," close & reopen the browser (Firefox), and then things seem to work okay.

Since we have multiple boxes running Win10, but this is the only computer that has this behavior, I highly doubt that it's a bug in the software. It's something unique about this particular box. This could be some kind of subtle multiple attack; with one intrusion to turn off the Secure Search. If McAfee would tell me where their config file is, that remembers the on/off setting, I could monitor to find out when/how the setting was changed to "off."  Otherwise to be sure I may have to re-install Win10 on this box from scratch, which is a bit of trouble.  @shannonslocker, are you still experiencing this effect, do you have any more information about what causes it?  Have you re-installed Windows and if so, did that solve the issue?