cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Unable to remove Secure Search as default on IE11

Jump to solution

My computer recently did an update and for some unknown reason, it has included Secure Search in my search engines now and I hate Yahoo.  I can pull up my Google search on the top and it will immediately revert back to Yahoo!  I have seen the suggestions for uninstalling SiteAdvisor and I have done that.  However, the McAfee search icon still appears in my search engine settings, and when I go to internet options to change it, the "disable" and "remove" buttons are greyed out.  I searched through my files on my C drive and found a SiteAdvisor folder in a different location, but it says it needs administrator to remove.  How can I get this thing off my computer???

1 Solution

Accepted Solutions
Highlighted

Re: Unable to remove Secure Search as default on IE11

Jump to solution

I tried all the above with no luck.  Even after rebooting, Secure Search kept coming up as default browser.

What DID work - I had to set one of the other browsers as "default" first.  THEN the "remove" button for Secure Search became enabled and I was finally able to remove it.

Hope this helps someone else with this issue!

View solution in original post

9 Replies
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 10

Re: Unable to remove Secure Search as default on IE11

Jump to solution

,

                    Try going to your Manage Add-Ons/Right click on Yahoo Secure Search,and see if you can disable. See if any other Search Providers are Listed/Available. If not try this link and select either Google or your preference of Search Providers/Make it your default Search Provider. Internet Explorer Gallery

                      May I ask what Version of Site Advisor were you running?

All the very Best

Catdaddy

McAfee Community Modrator

Consumer Products

Cliff
McAfee Volunteer
Highlighted

Re: Unable to remove Secure Search as default on IE11

Jump to solution

At some stage you must have clicked OK to the "Make Secure Search your search engine?" pop-up.  At present Yahoo is the only search engine offering this feature, but it can be turned off.

You should be able to turn it off by going to any web page in Internet Explorer, click to the right of the SiteAdvisor icon at the top of that page, select Options.  Go to the Secure Search section and disable it there.

Restart the browser and it should then be possible to alter your search engine in browser options.  You may have to reboot for it to take effect in all browsers.

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 4 of 10

Re: Unable to remove Secure Search as default on IE11

Jump to solution

That should work also. However you will need to enter your Password and Hint then click save/and close and reopen browser as Colleague Ex_Brit Stated.

Cliff
McAfee Volunteer
Highlighted

Re: Unable to remove Secure Search as default on IE11

Jump to solution

I just tested it by turning it on and then off again and I didn't need to do anything other than restart IE between each operation.  No password.

(I've never tried it before actually so this was a learning curve for me).

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 6 of 10

Re: Unable to remove Secure Search as default on IE11

Jump to solution

Hmmmmm...When I was on Version 3.7.2.182 I had to. It asked for a Password/Hint before it would take?  Oh well...even better   Thanks....

Cliff
McAfee Volunteer
Highlighted

Re: Unable to remove Secure Search as default on IE11

Jump to solution

Maybe I found a way around that, strange.   Anyway, just trying to help 😉

Highlighted

Re: Unable to remove Secure Search as default on IE11

Jump to solution

I tried all the above with no luck.  Even after rebooting, Secure Search kept coming up as default browser.

What DID work - I had to set one of the other browsers as "default" first.  THEN the "remove" button for Secure Search became enabled and I was finally able to remove it.

Hope this helps someone else with this issue!

View solution in original post

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 9 of 10

Re: Unable to remove Secure Search as default on IE11

Jump to solution

,

                       Glad to see that all worked out for you, and all is OK If you feel assured that your issue has been resolved, could you kindly mark appropriately this thread to be correctly answered? You might want to re-install Site Advisor since you made another Browser your preference/choice. Or at least (Wot) which is similar to Site Advisor.

All the very Best

Catdaddy

McAfee Community Moderator

Consumer Products

Cliff
McAfee Volunteer
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 10 of 10

Re: Unable to remove Secure Search as default on IE11

Jump to solution

,

                    Actually with your Consent/Approval I can personally mark your Comments/Solution as the Correct Answer. Since you seemed to figure it out on your own.

                    I see that one of my Colleague,s has done so already

Regards,

CD

Cliff
McAfee Volunteer
How Many Badges Can You Collect?
Ready for a little competition? Members like you are earning badges and unlocking perks for their helpful answers. Are you? Click here to find out.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community