cancel
Showing results for 
Search instead for 
Did you mean: 

Please Help!

After attempting to remove SiteAdvisor I still have the Checkmarks, X's, and ? marks indicating a site's safety rating next to all my links. The SiteAdvisor button in the tray of my browser is gone, but not the link to the site details link. I hoped after removing it (and even uninstalling and reinstalling FireFox) it would fix this problem, but it hasn't.. I just want to remove all traces of this program/add-on (for personal reasons, please don't ask). If anyone can offer any help i will be eager to receive it.
7 Replies
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 8

RE: Please Help!

Did you reboot after removing SiteAdvisor from the Control Panel/Add or Remove panel? There is no specific removal tool for SiteAdvisor but there is for McAfee in general, assuming all versions are within the last 2 or 3 years.

1. Uninstall all McAfee programs through "Add or Remove Programs" in Windows "Control Panel".

2. Use the MCPR tool, see this article: How to remove supported McAfee consumer products using the McAfee Consumer Products Removal tool (MC... This will remove all McAfee remnants from your computer. (you must have Windows Vista, XP or 2000 SP4 to use this tool)

3. Launch Windows Explorer and delete all McAfee files in "Program Files" but especially in "C:\Document and Settings\<user>\Application Data" and "C:\Document and Settings\All Users\Application Data". You have to set Windows Explorer to show all hidden files and folders (Tools > Folder Options > View tab). Just delete the McAfee folders even if they are empty in all the "Application Data" folders. Can be more than one!
In Vista: C:\Program Files, C:\ProgramData and C:\Users\yourname\AppData\Roaming

4. Reboot and redownload/reinstall your McAfee products directly from your account at the McAfee web site.

Fixed it... Mostly

For some reason, the checkmark, x, ? link still appears (without the checkmark, x, or ? picture), but only on CNET's download.com.. The link remains, but the picture is now gone.
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 4 of 8

RE: Fixed it... Mostly

Are you sure that it's a Siteadvisor issue? Do you have IE's Content Advisor turned on?

RE: Fixed it... Mostly

No, I don't even use IE. I only use FireFox. And this didn't start happening until I installed SiteAdvisor.
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 6 of 8

RE: Fixed it... Mostly

Well that's weird. All I can suggest is the drastic measure mentioned above.

RE: Fixed it... Mostly

Oh well, I guess I can live with it. Thanx for the help.
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 8 of 8

RE: Fixed it... Mostly

Good luck.Smiley Happy
Member Rewards
McAfee Community rewards active and helpful members just like you. Click here to take a look at the first community members who received a special reward and were recognized by McAfee leader, Aneel Jaeel, for their participation and trusted knowledge in the community.