cancel
Showing results for 
Search instead for 
Did you mean: 
josh44
Level 7
Report Inappropriate Content
Message 1 of 2

Citrix easy access desktop not working with McAfee Security Center

About 3 weeks ago I was able to use Citrix easy access desktop (EAD) to gain access to my at work desktop to check my emails and such but now I can't open Citrix EAD. I can get to the point of clicking the link as I always have but it only shows that its loading for about 3 seconds, sometimes a "running antivirus software" pops up at the bottom of the screen and then in 3 seconds its gone, and no window pops up for the EAD. I tried switching to compatibility mode on internet explorer 11 which is up to date but nothing works. I also tried using FireFox, Chrome, and Safari and had even worse results and couldn't get as far as I did before. I even tried calling IT at work and they couldn't help me. The problem seems to be with McAfee as I noticed one other person was having this problem on the forum but no solution was given. Anyone have any ideas?

1 Reply
Highlighted
Reliable Contributor exbrit
Reliable Contributor
Report Inappropriate Content
Message 2 of 2

Re: Citrix easy access desktop not working with McAfee Security Center

You probably need to give whatever software is associated with it full access in Firewall > Internet Connections for Programs and maybe open a port but what I am not quite sure.

Technical Support may be able to help as I believe McAfee uses Citrix internally, so they should know.  It;s free of charge and linked under Useful Links at the top of this page.

Member Rewards
McAfee Community rewards active and helpful members just like you. Click here to take a look at the first community members who received a special reward and were recognized by McAfee leader, Aneel Jaeel, for their participation and trusted knowledge in the community.