cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

yum error when upgrading to 7.8.2

Good day!

I am trying to upgrade from 7.7.2 to 7.8.2 and while running the upgrade, we get the following:

# yum update
Loaded plugins: changelog, fastestmirror
Setting up Update Process
Loading mirror speeds from cached hostfile
* mlos-7.8.2.15-gen_release-base: appliance.webwasher.com
Resolving Dependencies
--> Running transaction check
---> Package curl.x86_64 0:7.29.0-35.mlos2.mwg will be updated
---> Package curl.x86_64 0:7.29.0-42.mlos2.mwg.1 will be an update
---> Package dhclient.x86_64 12:4.1.1-36.mlos2 will be updated
---> Package dhclient.x86_64 12:4.1.1-55.mlos2 will be an update
---> Package dhcp.x86_64 12:4.1.1-36.mlos2 will be updated
---> Package dhcp.x86_64 12:4.1.1-55.mlos2 will be an update
---> Package glibc.i686 0:2.12-19.mlos2.mwg will be updated
---> Package glibc.i686 0:2.12-20.mlos2.mwg will be an update
---> Package glibc-utils.x86_64 0:2.12-19.mlos2.mwg will be updated
---> Package glibc-utils.x86_64 0:2.12-20.mlos2.mwg will be an update
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.131-1.mlos2 will be updated
---> Package java-1.8.0-openjdk.x86_64 1:1.8.0.171-8.mlos2 will be an update
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.131-1.mlos2 will be updated
---> Package java-1.8.0-openjdk-headless.x86_64 1:1.8.0.171-8.mlos2 will be an update
---> Package libcurl.i686 0:7.29.0-35.mlos2.mwg will be updated
---> Package libcurl.x86_64 0:7.29.0-35.mlos2.mwg will be updated
---> Package libcurl.i686 0:7.29.0-42.mlos2.mwg.1 will be an update
---> Package libcurl.x86_64 0:7.29.0-42.mlos2.mwg.1 will be an update
---> Package libgomp.x86_64 0:4.4.7-16.mlos2 will be updated
---> Package libgomp.x86_64 0:4.4.7-19.mlos2 will be an update
---> Package libssh2.i686 0:1.4.2-3.mlos2 will be updated
---> Package libssh2.x86_64 0:1.4.2-3.mlos2 will be updated
---> Package libssh2.i686 0:1.8.0-1.mlos2.mwg will be an update
---> Package libssh2.x86_64 0:1.8.0-1.mlos2.mwg will be an update
---> Package libstdc++.x86_64 0:4.4.7-16.mlos2 will be updated
---> Package libstdc++.x86_64 0:4.4.7-19.mlos2 will be an update
---> Package libxml2.i686 0:2.7.6-22.mlos2 will be updated
---> Package libxml2.i686 0:2.7.6-22.1.3.mlos2.mwg will be an update
---> Package libxml2-python.x86_64 0:2.7.6-22.mlos2 will be updated
---> Package libxml2-python.x86_64 0:2.7.6-22.1.3.mlos2.mwg will be an update
---> Package lm_sensors.x86_64 0:3.3.1-2.mlos2 will be updated
---> Package lm_sensors.x86_64 0:3.3.1-2.1.mlos2.mwg will be an update
---> Package mwg.x86_64 0:7.7.2.3.0-23892.mlos2.mwg will be updated
---> Package mwg.x86_64 0:7.8.1.6.0-26087.mlos2.mwg will be an update
---> Package mwg-mfetsc.x86_64 0:7.7.2.3.0-23892.mlos2.mwg will be updated
---> Package mwg-mfetsc.x86_64 0:7.8.1.6.0-26087.mlos2.mwg will be an update
---> Package mwg-release.noarch 0:7.7.2.3.0-23892.mlos2.mwg will be updated
---> Package mwg-release.noarch 0:7.8.1.6.0-26087.mlos2.mwg will be an update
---> Package mwg-ui.noarch 0:7.7.2.3.0-23892.mlos2.mwg will be updated
---> Package mwg-ui.noarch 0:7.8.1.6.0-26087.mlos2.mwg will be an update
--> Processing Dependency: xorg-x11-server-Xvfb for package: mwg-ui-7.8.1.6.0-26087.mlos2.mwg.noarch
--> Processing Dependency: icedtea-web for package: mwg-ui-7.8.1.6.0-26087.mlos2.mwg.noarch
--> Processing Dependency: daemonize for package: mwg-ui-7.8.1.6.0-26087.mlos2.mwg.noarch
---> Package ntp.x86_64 0:4.2.8p10-4.mlos2 will be updated
---> Package ntp.x86_64 0:4.2.8p11-2.mlos2 will be an update
---> Package ntpdate.x86_64 0:4.2.8p10-4.mlos2 will be updated
---> Package ntpdate.x86_64 0:4.2.8p11-2.mlos2 will be an update
---> Package opensaml.x86_64 0:2.4.3-4.mlos2.mwg.1 will be updated
---> Package opensaml.x86_64 0:2.6.1-1.mlos2.mwg will be an update
--> Processing Dependency: liblog4shib.so.1()(64bit) for package: opensaml-2.6.1-1.mlos2.mwg.x86_64
---> Package openssl-libs.i686 1:1.0.2k-1.mlos2.mwg.1 will be updated
---> Package openssl-libs.i686 1:1.0.2n-1.mlos2.mwg will be an update
---> Package xalan-c.x86_64 0:1.10.0-7.mlos2.mwg.1 will be updated
---> Package xalan-c.x86_64 0:1.11.0-3.mlos2.mwg will be an update
---> Package xerces-c.x86_64 0:3.0.1-20.mlos2.mwg.1 will be updated
---> Package xerces-c.x86_64 0:3.1.1-8.mlos2.mwg will be an update
---> Package xml-security-c.x86_64 0:1.6.0-2.mlos2.mwg.4 will be updated
---> Package xml-security-c.x86_64 0:1.7.3-1.mlos2.mwg will be an update
---> Package xmltooling.x86_64 0:1.4.2-5.mlos2.mwg.3 will be updated
---> Package xmltooling.x86_64 0:1.6.4-1.mlos2.mwg will be an update
--> Running transaction check
---> Package daemonize.x86_64 0:1.7.3-1.mlos2 will be installed
---> Package icedtea-web.x86_64 0:1.6.2-1.mlos2.mwg.2 will be installed
--> Processing Dependency: tagsoup for package: icedtea-web-1.6.2-1.mlos2.mwg.2.x86_64
---> Package log4shib.x86_64 0:1.0.9-1.mlos2.mwg will be installed
---> Package xorg-x11-server-Xvfb.x86_64 0:1.17.4-16.mlos2.mwg will be installed
--> Processing Dependency: libGL.so.1()(64bit) for package: xorg-x11-server-Xvfb-1.17.4-16.mlos2.mwg.x86_64
--> Processing Dependency: libXfont.so.1()(64bit) for package: xorg-x11-server-Xvfb-1.17.4-16.mlos2.mwg.x86_64
--> Processing Dependency: libxshmfence.so.1()(64bit) for package: xorg-x11-server-Xvfb-1.17.4-16.mlos2.mwg.x86_64
--> Running transaction check
---> Package libXfont.x86_64 0:1.5.1-2.mlos2.mwg will be installed
--> Processing Dependency: libfontenc.so.1()(64bit) for package: libXfont-1.5.1-2.mlos2.mwg.x86_64
---> Package libxshmfence.x86_64 0:1.2-1.mlos2.mwg will be installed
---> Package mesa-libGL.x86_64 0:10.4.3-1.mlos2.mwg will be installed
--> Processing Dependency: mesa-dri-drivers(x86-64) = 10.4.3-1.mlos2.mwg for package: mesa-libGL-10.4.3-1.mlos2.mwg.x86_64
--> Processing Dependency: libdrm >= 2.4.24-1 for package: mesa-libGL-10.4.3-1.mlos2.mwg.x86_64
--> Processing Dependency: libdrm.so.2()(64bit) for package: mesa-libGL-10.4.3-1.mlos2.mwg.x86_64
--> Processing Dependency: libglapi.so.0()(64bit) for package: mesa-libGL-10.4.3-1.mlos2.mwg.x86_64
---> Package tagsoup.noarch 0:1.2.1-8.mlos2.mwg will be installed
--> Running transaction check
---> Package libdrm.x86_64 0:2.4.65-2.mlos2.mwg will be installed
--> Processing Dependency: libpciaccess.so.0()(64bit) for package: libdrm-2.4.65-2.mlos2.mwg.x86_64
---> Package libfontenc.x86_64 0:1.1.2-3.mlos2.mwg will be installed
---> Package mesa-dri-drivers.x86_64 0:10.4.3-1.mlos2.mwg will be installed
--> Processing Dependency: mesa-dri1-drivers >= 7.11-6 for package: mesa-dri-drivers-10.4.3-1.mlos2.mwg.x86_64
--> Processing Dependency: libLLVM-3.4-mesa.so(libLLVM-3.4-mesa.so)(64bit) for package: mesa-dri-drivers-10.4.3-1.mlos2.mwg.x86_64
--> Processing Dependency: libLLVM-3.4-mesa.so()(64bit) for package: mesa-dri-drivers-10.4.3-1.mlos2.mwg.x86_64
--> Running transaction check
---> Package libpciaccess.x86_64 0:0.13.4-1.mlos2.mwg will be installed
---> Package mesa-dri1-drivers.x86_64 0:7.11-8.mlos2.mwg will be installed
---> Package mesa-private-llvm.x86_64 0:3.4-3.mlos2.mwg will be installed
mlos-7.8.2.15-gen_release-base/filelists | 1.3 MB 00:00
--> Finished Dependency Resolution
Error: Multilib version problems found. This often means that the root
cause is something else and multilib version checking is just
pointing out that there is a problem. Eg.:

1. You have an upgrade for libxml2 which is missing some
dependency that another package requires. Yum is trying to
solve this by installing an older version of libxml2 of the
different architecture. If you exclude the bad architecture
yum will tell you what the root cause is (which package
requires what). You can try redoing the upgrade with
--exclude libxml2.otherarch ... this should give you an error
message showing the root cause of the problem.

2. You have multiple architectures of libxml2 installed, but
yum can only see an upgrade for one of those arcitectures.
If you don't want/need both architectures anymore then you
can remove the one with the missing update and everything
will work.

3. You have duplicate versions of libxml2 installed already.
You can use "yum check" to get yum show these errors.

...you can also use --setopt=protected_multilib=false to remove
this checking, however this is almost never the correct thing to
do as something else is very likely to go wrong (often causing
much more problems).

Protected multilib versions: libxml2-2.7.6-22.1.3.mlos2.mwg.i686 != libxml2-2.7.6-22.mlos2.x86_64
Error: Protected multilib versions: 1:openssl-libs-1.0.2n-1.mlos2.mwg.i686 != 1:openssl-libs-1.0.2k-1.mlos2.mwg.1.x86_64
Error: Protected multilib versions: glibc-2.12-20.mlos2.mwg.i686 != glibc-2.12-19.mlos2.mwg.x86_64

1 Reply
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 2

Re: yum error when upgrading to 7.8.2

Hi Mike,

From your description, I understand that currently, you are running in version 7.7.2.x. An upgrade to 7.8.2.x version it will be a phased upgrade.

This is a phased upgraded from MLOS2 to MLOS 3. Till 7.8.1.6, it is MLOS2 and then it is MLOS3.  As this is phased upgrade first it will upgrade to version 7.8.1.6. For an upgrade from MLOS2-MWG (older than 7.8.2.0) to MLOS3-MWG (>= 7.8.2.0) in one go, the following procedure should work:-

To upgrade MWG 7.8.2.x in one step:

mwg-switch-repo main or mwg-switch-repo --sticky <mwg version>

yum clean all              # optional.

yum upgrade yum            # this will install yum + mlos3-upgrade package.

yum upgrade mlos3-upgrade  # if the mlos3-upgrade package not installed this will upgrade the mlos3-upgrade package or if old version of mlos3-upgrade is installed.

yum upgrade                # this command should start the mlos3-upgrade process which will automatically upgrade to 7.8.1.6 -> 7.8.2.0 -> 7.8.2.x 

reboot                     # The mlos3-upgrade process will do a system reboot which automatically if the upgrade will complete successfully.

NOTE:-  Above steps will work assuming you have direct internet access provided for web gateway.

Before performing this upgrade, please take a backup of the config.

We suggest doing upgrades via the command line and the "yum" command. This gives you more control and visibility into the process. Please make sure you have root access to the command line for this.

Finally, always reboot the appliance after upgrading.

Please refer below link for more information on MWG upgrade:-

https://community.mcafee.com/t5/Documents/Web-Gateway-Upgrade-Best-Practices-and-Understanding-Relea...

https://kc.mcafee.com/corporate/index?page=content&id=KB89192&elqTrackId=D824897F4BE515C4A655E2D408F...

Please log the Putty Session when you perform the upgrade.

If the above steps don't help, do raise a Support SR and share the Putty Session Logs and the Feedback File so that we can understand the cause of the problem.

Thanks,

Shibani

 

 

 

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community