cancel
Showing results for 
Search instead for 
Did you mean: 
nsgmike
Level 7

website not loading properly - web gateway 7

I ran into a couple websites not loading properly in IE 7 or firefox, download.com and boston.com

download.com loads fine in IE 6. I created a whitelist rule for the website and also an http cache rule, still does not solve my issue.

What would be my other options? Some type of media filter rule?

0 Kudos
7 Replies
nsgmike
Level 7

Re: website not loading properly - web gateway 7

FYI

I took the advice of the below post to change MediaType.EnsuredTypes all in list Antimalware Media Type Whitelist to MediaType.FromHeader is in list Antimalware Media Type Whitelist and it has corrected both issues with the websites not loading properly.

Just assuming...

Flash is a  streaming media type, therefore it is difficult to be proxied. We have  bypass rules in the library, which today require the full object to be  loaded in order to make a decision on the bypass. The browser  waits..waits...waits and then gives up, thus wrongly rendered pages. I  suggest changing this rule from the one in blue to the one in the  foreground and retry.

GAM.jpg

thanks,

Michael

--

CISSP

Sr. Product Manager MWG

Content & Cloud Security BU

0 Kudos
puliyadim
Level 7

Re: website not loading properly - web gateway 7

Hi Michael,

I already have this rule under the Gateway Antimalware, however some of the flash contents are unable to load, for ex www.burjkhalifa.ae.

Rgds,

Dinesh

0 Kudos
dcaffrey
Level 10

Re: website not loading properly - web gateway 7

That page loads Ok for me with MWG7 (7.0.1.5.0), I have a couple of exceptions on the Progress Page rule to ensure PDF's and Flash are not treated as downloads

MediaType.EnsuredTypes does not contain application/pdf

MediaType.EnsuredTypes does not contain video/x-flv

0 Kudos
puliyadim
Level 7

Re: website not loading properly - web gateway 7

Hello,

May I know where and how to add the necessary exceptions on the Progress Page rule for PDF's and Flash? Thanks in advance.

Rgds,

Dinesh

0 Kudos
dcaffrey
Level 10

Re: website not loading properly - web gateway 7

Hi Dinesh,

Here is how I have configured the Progress Page Rule.

Dec

MWG01.gif

MWG02.gif

0 Kudos
puliyadim
Level 7

Re: website not loading properly - web gateway 7

Fantastic, it works. Thanks for the help.

0 Kudos
dcaffrey
Level 10

Re: website not loading properly - web gateway 7

You're welcome

0 Kudos