cancel
Showing results for 
Search instead for 
Did you mean: 
wajeeh_r
Level 9

https version of youtube is working

Dear All,

Our web gateway appliance is using 7.5.2.5 version and I am looking to block access to youtube, but noticed that people still able to play it. When saw it carefully found that 'http' version is not working while 'https' version is running,

In chrome, even if you type youtube.com it automatically goes to https://youtube.com

While in IE and firefox, only https version is working while if typing youtube.com it  tells it is blocked by web gateway, how to control it completely?

regards,

0 Kudos
6 Replies
asabban
Level 17

Re: https version of youtube is working

Hello,

do you have SSL Scanner enabled?

Best,

Andre

0 Kudos
wajeeh_r
Level 9

Re: https version of youtube is working

Yes, we have ssl scanner and it is also enabled

0 Kudos
asabban
Level 17

Re: https version of youtube is working

In that case you should be able to block Youtube.What rule are you using to block Youtube? Are you blocking it via the URL Filter rules or do you have a special rule for blocking Youtube (if so, can you share it?)?

Best,

Andre

0 Kudos
wajeeh_r
Level 9

Re: https version of youtube is working

Hello,

Yes, now I created rule added under SSL scanner, and when attempting to use by 'http://youtube.com' I see mcafee page showing it is blocked by URL filtering, but when I attempt to open it using'https://youtube.com' I have different message see attached, it should also be same like 'blocked by URL filtering'

youtube-ssl-scanner.jpghttpsyoutube-message-browser.jpg

Ok if we are doing above youtube is completely blocked and what is the possibility of using Application control to only allow videos uploaded by 'HP, Intel, Oracle' to load and play.

This was a facility of Mcafee when we bought the appliances, but later due to some change in youtube everything started working. Now what is the possibility for this?

Regards

0 Kudos
dpereziii
Level 7

Re: https version of youtube is working

Have you issued the CA from your MWG? Maybe there's no SSL handshake being made. See if the link below helps.

0 Kudos
asabban
Level 17

Re: https version of youtube is working

Hello,

if you see the error message on the right it means that MWG is answering with an HTTP response to the browser while it expects an HTTPS response. You should have a "Enable SSL Client Context With CA" Event called somewhere before the block action for Youtube happens in order to allow MWG to send a proper error message.

Best,

Andre

0 Kudos