cancel
Showing results for 
Search instead for 
Did you mean: 
michael-s-w
Level 9

WebGateway 7.3.1 - CPU Utilisation takes 100% during several hours

Hi together,

we notice a CPU Utilisation with 100% during 2 or three hours somtimes during one day (24 hours) on one of our appliances, which are running in a cluster. It is not every time the same appliance, this is changing. We think, that there is a big volume which gets scanned.

Now the question:

Is there any possibility to take a look inside, what sort of data is in process and what a service is running so intensive?

Thanks a lot for your answers

greetings from

Michael (Wuppertal)

0 Kudos
2 Replies
McAfee Employee

Re: WebGateway 7.3.1 - CPU Utilisation takes 100% during several hours

Hi Michael,

Support can help you out if you provide a feedback file (DO NOT POST IT HERE).

You can take a look at the feedback yourself to see what is going on.

In particular, it would be interesting to see what antimalware is doing (see commands below):

# shows active threads being scanned by antimalware

/opt/mwg/bin/mwg-antimalware -S threads

# shows threads waiting to be scanned by anti-malware

/opt/mwg/bin/mwg-core -S AMQueue

If you look at 'top' what is the process using the most CPU? This will give you and I better direction as to where to start looking.

The above commands would be issued from the CLI.

Best,

Jon

0 Kudos
michael-s-w
Level 9

Re: WebGateway 7.3.1 - CPU Utilisation takes 100% during several hours

Hi Jon,

that was very helpful - thanks a lot for this fast answer.

As I wish now I can see, what sort of data gets scanned at this point of time - and how much data or files will getting scanned next.

By "top" - instruction I could only see, whats global is going on in the appliance, with this "new" instructions it is much more detailed.

Thanks a lot - very helpful for me!

Greetings from

Michael

0 Kudos