cancel
Showing results for 
Search instead for 
Did you mean: 
puliyadim
Level 7

Web Reporter - Active Directory

Hi There,

Does anyone know the value of the "Group Key" under the Active Directory advance configuration in McAfee Web Reporter? I have a need to pull out group details from MWG (7.X) logs for reporting.

Rgds,

Dinesh

0 Kudos
11 Replies
dcaffrey
Level 10

Re: Web Reporter - Active Directory

Hi,

Did you solve this ?

Thanks,

Dec

0 Kudos
puliyadim
Level 7

Re: Web Reporter - Active Directory

Not yet.

0 Kudos
dcaffrey
Level 10

Re: Web Reporter - Active Directory

I've just put in memberof for the Group Key and it seems to be working, although it does highlight issues with multi group membership

0 Kudos
puliyadim
Level 7

Re: Web Reporter - Active Directory

Currently this is the input "memberof" for the group key, but in my case the reporter does not display any group information under the quick view - user groups.

0 Kudos
dcaffrey
Level 10

Re: Web Reporter - Active Directory

I think you have to run a custom query in Reporter first using the Group - Search Directory Filter and then update your directory before this attribute is populated into the database

0 Kudos
puliyadim
Level 7

Re: Web Reporter - Active Directory

I did try to create a query with "user group" but no data. What directory are u using? AD?

0 Kudos
dcaffrey
Level 10

Re: Web Reporter - Active Directory

I'm using AD, but I had to run a custom query first as described in the Web Reporter Product Guide page 35 "Associate Users with Groups"

Quote

Groups appear in Web Reporter only after Web Reporter starts tracking group membership. For Web
Reporter to track group membership, it first must obtain a list of groups from a directory. When this
happens, Web Reporter tracks group membership during log file processing and directory updates.

0 Kudos
pkonitz
Level 7

Re: Web Reporter - Active Directory

hi,

Its old topic but I don't want to create the new one

I did what was described in product guide but I still got problems with some groups.

AD groups starts showing in  quick vew / summary but not all of them !!!

For example:

In filters I included dept IT, Dept Finance, Dept Marketing, ProxyFullAccess etc

but only  some of these are displayed. When I do report I see every Group even when user is member of many.

Again example:

I see in quick vew dept IT, dept Finance, ProxyFullAccess but no Dept Marketing.

user: john is member of dept IT and ProxyFullAccess and when I click these groups and display usernames  I see him on both places.

however there is another user alice (in groups ProxyFullAccess and Dept Marketing) but I see her only in ProxyFullAccess and no Dept Marketing group is present.

does anyone have similar issues?

regards

Przemek

0 Kudos
sroering
Level 13

Re: Web Reporter - Active Directory

if users are not showing in groups, you have to first verify that they are associated with the directory. Go to

Administration > Tools > Database Maintenance > Manual Maintenance > Synchronize Users

That will check users who are not in a directory and try to move them into a directory if possible. Then go to

Administration > Setup > Directories > Seclect Directory > Click Update Now button

That will check for group memberships.

0 Kudos