cancel
Showing results for 
Search instead for 
Did you mean: 
orosales
Level 8

Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

Ntlm authentication fails and browser prompts for credentials when im using Mozilla firefox (Works if configurate the http proxy manually on the browser) or other Internet Browsers, only works with IE8, all the computer are part of a domain, have any idea whats the problem

El mensaje fue editado por: Oscar Rosa on 28/09/10 12:47:24 CDT
0 Kudos
8 Replies
McAfee Employee

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

In IE, your browser automatically sends the credentials because it must be added to the Trusted Sites / Intranet Zone. In firefox you need to add the Web Gateway to the 'network.negotiate-auth.trusted-uris'. This procedure is outlined in our KB (see: https://kc.mcafee.com/corporate/index?page=content&id=KB67094) this article describes it in general, not specific to Web Gateway.

~Jon

0 Kudos
orosales
Level 8

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

Hi i tried it and didn't work the same problem, its there another way to resolve it ??

El mensaje fue editado por: Oscar Rosa on 29/09/10 12:31:03 CDT
0 Kudos
DnrTech
Level 9

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

It is a setting in Firefox that needs to be changed. Go to about:config and look for netowrk.automatic-ntlm-auth.trusted-uris. Set that to the ip address or name of the gateway and it should fix the problem. This link takes you to a script you can use to run in a login script or something that will set it for you. You just have to edit the vb script and change one variable to add your server to it.

http://sivel.net/2007/05/firefox-ntlm-sso/

0 Kudos
orosales
Level 8

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

Hello, it dint work, im having the same problem, i add the ip and nothing happens, add the name of the webgateway and nothing happens

0 Kudos
DnrTech
Level 9

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

Sorry, I am out of ideas, then. The two settings that Jon linked to and the one I mentioned are the only ones i've seen to cause this problem by not being set right. It is odd that it works fine if you manually configure the proxy settings, though.

0 Kudos
asabban
Level 17

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

Hello,

I think at this situation it may be a good approach to file a ticket with Support. We would definitely like to understand and solve that issue. It will probably result into a KB article that may be interesting for others as well.

I recommend to work with Tech Support.

Best,

Andre

0 Kudos
orosales
Level 8

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

ok, i will open a support case and post the results

0 Kudos
McAfee Employee

Re: Web Gateway 7.x Transparent bridge NTLM authentication Fails with firefox

I just found something interesting related to this thread. You can create an autoconfig script which will be read by firefox on startup.

http://web.mit.edu/~firefox/www/maintainers/autoconfig.html

You can create a file called "firefox.js" in the "C:\Program Files\Mozilla Firefox\defaults\pref" folder, and Firefox will read it on startup.

pref("network.automatic-ntlm-auth.trusted-uris", "WEBGATEWAY-ADDRESS");

You can then push it out via GPO magic.

I havent tested it, but thought I'd put it out there for general consumption.

Best,

Jon

0 Kudos