cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Trying to understand MWG authentication a little better.

My company uses McAfee Web Gateway 7.6.2 and I'm one of the administrators.

I often get tickets where users access a website and the entire site won't load, parts of the site won't load, or the site will load but once they login, some part of it doesn't work.

For instance, I had a ticket today where the user could access join.me but once they tried to join a session, it would give her some type of error originating from join.me.

These almost always end up being due to our authentication rule.

Our rule is pretty simple in my opinion. See the image below.

So my questions are:

  1. What exactly does authentication do in MWG?
  2. What steps does it go through?
  3. Does it use the authentication rule for every element of a website?
  4. Is there a best practice that I'm missing?

Thanks for any help and advice!

Here's a screenshot of our authentication rule:

Capture.PNG

- Devante

2 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: Trying to understand MWG authentication a little better.

Devante,

please keep in mind such Applications like join.me and other remote tools load Java Applets to connecto to remore server. This create new connection from Client. Authentication rule set will check if the first request is already authenticated. If not, the web gateway send 407 Authentication Required. Most likely if application doesn't support proxy it will ignore 407 and continue sending requests. The result is - you end up in loop where web gateway correctly request the client to authenticate and the client ignore this.

More about NTLM authentication is published in our Best Practice guide:

https://community.mcafee.com/docs/DOC-4918#jive_content_id_Troubleshooting

-Sergej

McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 3 of 3

Re: Trying to understand MWG authentication a little better.

Hi Devante,

Sergej might be onto something with the applications failing auth, but if he's not, here's my theory.

Looking at the screenshot of your authentication rules, they look to have been created manually rather than imported from the library.

I can tell this because the ruleset criteria is missing (Authentication.IsAuthenticated equals false AND Authentication.Failed equals false) at the top.

It might be worth a shot to add that criteria back in to see if it helps. Beyond that, SSL scanning is below authentication, which could be a culprit, but I'd start with the ruleset criteria first as it's a way smaller change.

See below screenshot from this guide:

Best Regards,

Jon

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community