cancel
Showing results for 
Search instead for 
Did you mean: 
RayP
Level 7

The proxy did not receive a valid response in time. If I don't use the webgateway the website is visible.

Used gateways: Web Gateway 7 version 7.1.6.1.0 (12742)

When users want to access the following website (http://ire.eciq.cn/), they receive:

The proxy did not receive a valid response in time.

URL: http://ire.eciq.cn/

If I don't use the webgateway the website is visible.

Connection tracing within "Troubleshooting" shows me:

13:56:00.007: Receive: Would Block (EPOLLIN, EPOLLONESHOT)

13:56:31.166: Received 382 bytes

>>>

GET http://ire.eciq.cn/ HTTP/1.1

Accept: */*

Accept-Language: en-us

User-Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.2; Trident/4.0; .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729)

Accept-Encoding: gzip, deflate

If-Modified-Since: Thu, 11 Oct 2012 21:13:22 GMT

Host: ire.eciq.cn

Proxy-Connection: Keep-Alive

Pragma: no-cache

<<<

13:58:36.005: Send: errno: 104 - 'Connection reset by peer' (104); offset = 0

13:58:36.006: Shutdown with error 107

13:58:36.006: Releasing and closing FD (0)

Placing the url in the global whitelist on top of the rules doesn't work.

Who can help me.

Regards,
Ray

0 Kudos
4 Replies
jschnell
Level 9

Re: The proxy did not receive a valid response in time. If I don't use the webgateway the website is visible.

Hi Ray,

you posted the HTTP*-C.txt file. Would please post the coresponding HTTP*-S.txt file (completely).

Thanks

Jan

0 Kudos
asabban
Level 17

Re: The proxy did not receive a valid response in time. If I don't use the webgateway the website is visible.

Hello,

the website seems to take a long time until any response comes back. I think in MWG we have a timeout of around 10 seconds when no data comes back from the server. I think this is the problem. When you go to the web site, does it take a couple of seconds until you see something is happening in the browser?

Best,

Andre

0 Kudos
RayP
Level 7

Re: The proxy did not receive a valid response in time. If I don't use the webgateway the website is visible.

Hello Andre,

That's correct...it always take a while to load the website of China.

But not that long...always before 10 seconds.

Just to make sure, i've change the Intital connection timeout from 10 to 20 seconds.

But it still doesn't work.

Does anyone can test it behind his/her own webgateway?

http://ire.eciq.cn/

Regards,

Ray

Message was edited by: RayP on 11/2/12 7:25:58 AM CDT

Message was edited by: RayP on 11/2/12 7:28:32 AM CDT
0 Kudos
btlyric
Level 12

Re: The proxy did not receive a valid response in time. If I don't use the webgateway the website is visible.

If you know that the response from the destination site will be slow, you could configure a Proxy Control entry with an extended timeout for that specific destination.

For example, in rule set:

Enable Extended Timeout

Criteria: URL.Destination.IP is in range list Extended Timeout OR URL.Host matches in list Extended Timeout Host

Action: Continue

Events: Enable Proxy Control <Extended Timeout>

Add destination IP and/or destination host name to the respective Extended Timeout lists.

Configure Proxy Control->Extended Timeout with a timeout value that makes sense for that destination site.

0 Kudos