cancel
Showing results for 
Search instead for 
Did you mean: 
Yaling
Level 7

Safe search function in webgateway not working

Hi all, I enabled the safesearch function in default URL rule set. But it seems not working at all. attached the setting I made. How can I troubleshoot or someone can post a valid policy?

Thanks a lot.

0 Kudos
11 Replies
McAfee Employee

Re: Safe search function in webgateway not working

Hello Yaling,

what search engine are you using? We don't have all, so we'd need to know which one you are looking at.

thanks,

Michael

0 Kudos
Yaling
Level 7

Re: Safe search function in webgateway not working

I have tried goole and yahoo. there are no change about the search result before/after I apply the setting.

0 Kudos

Re: Safe search function in webgateway not working

What is the function of safesearchenforcer?  Docmentation doesn' explain how it works or what exactly it does. 

0 Kudos
fschulte
Level 10

Re: Safe search function in webgateway not working

Hi!

The safe search enforcer (SSE) checks if a request is a search request to some search engine. If a search request is detected the SSE modifies the request URL or Cookie (depending on the search engine) to tell the search engine that its safe search filter should be applied. The filtering is then done by the search engine. The SSE only enforces the safe search, hence the name.

Ciao

0 Kudos
ilya.magas
Level 10

Re: Safe search function in webgateway not working

Hi All

Guys the problem is still actual. What for do we need safesearchenforcer function and how can the safesearchenforcer can be used ?

0 Kudos
asabban
Level 17

Re: Safe search function in webgateway not working

There are no special requirements for the Safe Search Enforcer. It is part of the URL Filter Rule Set and all you can do is enable the Event "Enable Safe Search Enforcer" and choose between moderate and strict filtering. MWG is NOT doing any kind of filtering itself, what this feature does is enableing the filters that the search engine provider offers. In the Google preferences for example you can switch between "No Filtering", "Moderate Filtering" and "Strict Filtering".

All the Safe Search Enforcer does is overwriting the setting you have choosen. We do not have an integrated wordlist or list of "bad search terms", but only enable the filter, so when a user sends a search request, MWG adds an information that only strict results are allowed, before the request goes to google.com.

Unfortunately it is, at least for some search engines, hard to tell whether the results are filtered or not. You can check if the Event is workign as expecting by using the google image search. Go to www.google.com, seach for "Porsche" and then in the menu bar on the top choose "Images". On the image results page you should see if the search was filtered:

Auswahl_204.png

With the Safe Search Enforcer enabled you won´t be able to turn the filtering off. That´s the idea of the feature.

Best,

Andre

0 Kudos
squidward
Level 7

Re: Safe search function in webgateway not working

Any update on this issue?  I've compared the Google search setting both with and without the SafeSearch Enforcer enabled and see no difference.  Using MWG v7.2.0.1.0

0 Kudos
jschnell
Level 9

Re: Safe search function in webgateway not working

Hi,

are you using direct proxy mode or MWG as ICAP server?

Thanks

0 Kudos
squidward
Level 7

Re: Safe search function in webgateway not working

Direct proxy mode

0 Kudos