cancel
Showing results for 
Search instead for 
Did you mean: 
simon1976
Level 7

Problem with libgam.so on McAfee Web Gateway

Hi @ all,

sinces yesterday I have massive problems with our web gateways - the user had temporarly no access to the internet - the message in the browser shows: "The Anti-Malware engine is currently overloaded.... - Please try again later"


In the log file (/var/log/messages) I found entries like


[ 1396.710689] mwg-antimalware[4145]: segfault at 7fd9fa933f68 ip 00007fda0820d597 sp 00007fd9fa933f70 error 6 in libgam.so[7fda0802e000+7ac000]

The time stamp with the error message in the browser and the log entrys are matching. The file libgam.so was automatically updatet yesterday night - sinces then, we have problems.

In the nwg-core.error.log I found those entries:

[2016-03-30 08:12:27.005 +02:00] [AV] [ErrorVerifyingEngine] Failed to verify AntiVirus engine 'Anti-Malware'. Details: 'Scanning test data failed!'.

[2016-03-30 08:12:59.631 +02:00] [AV] [AVError] Error in AntivirusFilter: 'Scanning job couldn't be processed in time (current queue length is 483).'. 

..

..

[2016-03-30 08:13:41.710 +02:00] [ ERRORS LOG FLOOD - START ] 6 times within the last 0ms [812264D7A1949265][>>> [AV] [AVError] Error in AntivirusFilter: 'Scanning job couldn't be processed in time (current queue length is 1000).'. <<<]

[2016-03-30 08:13:41.710 +02:00] [AV] [AVError] Error in AntivirusFilter: 'Scanning job couldn't be processed in time (current queue length is 1000).

..

..

[2016-03-30 08:14:11.819 +02:00] [ ERRORS LOG FLOOD - START ] 6 times within the last 1ms [812264D7A1949265][>>> [AV] [AVError] Error in AntivirusFilter: 'Scanning job couldn't be processed in time (current queue length is 1000).'. <<<]

Does anyone else have this problem? I have contacted McAfee, but my ticket is still in progress....

0 Kudos
1 Reply

Re: Problem with libgam.so on McAfee Web Gateway

I've seen something similar today at one of my customers:

[ ERRORS LOG FLOOD - START] 6 times within the last 940ms [523A493F066E01D8][>>> [ICAPClientFilterPlugin]

[NoICAPServerAvailable] No ICAP server available from service: 'com.scur.type.complex.icapserver.490'

And in that time the CPU was overloaded, user sessions working very slow.

0 Kudos