cancel
Showing results for 
Search instead for 
Did you mean: 
svokac
Level 7

Problem with connection to web-gui after upgrade to 7.4

Dear friends,

I would like ask for your advice regarding problem we are experiencing after update two gateways running in cluster to version 7.4.

After upgrade reboot we are unable connect to web-gui of both appliances. Web interface on both nodes was configured to listen on port 9443 but after upgrade we we see that both nodes are listening on this port only on localhost interface and not on network interface.

netstat -tulpn | grep 443

tcp        0      0 ::ffff:127.0.0.1:9443       :::*                        LISTEN      7806/java

Can I ask how is possible to recover this problem?

Edit: in mwg-ui log I found this error:

Nov 03, 2014 4:24:54 PM org.apache.catalina.core.StandardService start

SEVERE: Failed to start connector [Connector[HTTP/1.1-9443]]

LifecycleException:  service.getName(): "Konfigurator";  Protocol handler start failed: java.lang.Exception: Socket bind failed: [98] Address already in use

        at org.apache.catalina.connector.Connector.start(Connector.java:1203)

        at org.apache.catalina.core.StandardService.start(StandardService.java:540)

        at org.apache.catalina.core.StandardServer.start(StandardServer.java:754)

        at org.apache.catalina.startup.Catalina.start(Catalina.java:595)

        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)

        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)

        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)

        at java.lang.reflect.Method.invoke(Method.java:606)

        at org.apache.catalina.startup.Bootstrap.start(Bootstrap.java:289)

        at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:414)

Many thanks,

Stan

0 Kudos
5 Replies
haaris
Level 10

Re: Problem with connection to web-gui after upgrade to 7.4

I also faced the same problem!!!!

It is recommended to upgrade the nodes after breaking the cluster.See KB KB76905

So break the cluster,upgrade individually & then add in cluster.All webgateway needs to be of same version

0 Kudos
svokac
Level 7

Re: Problem with connection to web-gui after upgrade to 7.4

Hello Haaris,

   problem is that we already can't access web GUI, is possible node remove from cluster via command line?

0 Kudos
haaris
Level 10

Re: Problem with connection to web-gui after upgrade to 7.4

Dear svokac,

I dont know how to remove it from cluster via command line.

But even if u are able to break it via command line how will u get the GUI???

Since u upgraded the webgateway,it cant b degraded,so u need to reimage the webgateway.

If there is any other way then support team might help u

0 Kudos
svokac
Level 7

Re: Problem with connection to web-gui after upgrade to 7.4

Hello so we got it sorted, problem was that in server.xml was missing configuration of IP where mwg-ui should listen.

Not sure if problem was caused by upgrade, but after reboot was appliance unable to bind any available network interface with error:

LifecycleException:  service.getName(): "Konfigurator";  Protocol handler start failed: java.lang.Exception: Socket bind failed: [98] Address already in use


Despite the fact that nothing was at this time listening on this port. After we manually updated server.xml and reloaded mwg-ui we were able to connect via web interface again.


Many thanks for all help, is really appreciated.


Stan

0 Kudos
haaris
Level 10

Re: Problem with connection to web-gui after upgrade to 7.4

Ok ,gud!!!Thats great

May be u have some diff error...

Could u please elaborate what exactly u did

0 Kudos