cancel
Showing results for 
Search instead for 
Did you mean: 
jelz
Level 7

Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi Guys,

I am trying to get physical diskstatus from McAfee Web gateway 6 by SNMP. So far I have been succesfull in retrieving the "standard" SNMP information, but not succesfull in getting the additional information as described in the guide "Advanced hardware monitoring for Webwasher appliances" written by Michael Schneider.

Following the I should be able to get info from the dcstorag.mib

1. I installed the srvadmin-snmp via yum.

2. I had set the global.SNMPAgent.SMUXEnabled  to 1

    admin@WWSNMPtest> get global.SNMPAgent.SMUXEnabled

    1

    admin@WWSNMPtest>

3. I performed a webwasher-csm service restart

4. I see the extra port on the MWG:

    [root@WWSNMPtest ~]# netstat -na

    Active Internet connections (servers and established)

    Proto Recv-Q Send-Q Local Address               Foreign Address             State

    tcp        0      0 127.0.0.1:199               0.0.0.0:*                   LISTEN

    tcp        0      0 0.0.0.0:9161                0.0.0.0:*                   LISTEN

    udp        0      0 0.0.0.0:9161                0.0.0.0:*

But when I try to retrieve information, it is not successfull:

    jelmar@tux-01:~ [63] % snmpwalk -v 2c -c pine tcp:192.168.20.189:9161 .1.3.6.1.4.1.674.10893.1.20.130   <-- using an OID from a new MIB

    SNMPv2-SMI::enterprises.674.10893.1.20.130 = No Such Object available on this agent at this OID

    jelmar@tux-01:~ [64] %

    jelmar@tux-01:~ [64] % snmpwalk -v 2c -c pine tcp:192.168.20.189:9161 .1.3.6.1.2.1.25.5.1.1.1    <-- using an already existing OID

    HOST-RESOURCES-MIB::hrSWRunPerfCPU.1 = INTEGER: 80

    HOST-RESOURCES-MIB::hrSWRunPerfCPU.2 = INTEGER: 24

    etc

I also tried to get information from the other OID's by performing a snmpwalk without specifying an OID, but this doesn't show more then the "regular" SNMP information without the extra OID's:

    SNMPv2-MIB::sysDescr.0 = STRING: Webwasher 6.9.0

    DISMAN-EVENT-MIB::sysUpTimeInstance = Timeticks: (82718) 0:13:47.18

    IF-MIB::ifNumber.0 = INTEGER: 2

    RFC1213-MIB::atIfIndex.1.1.192.168.20.1 = INTEGER: 1

    IP-MIB::ipForwarding.0 = INTEGER: notForwarding(2)

    TCP-MIB::tcpRtoAlgorithm.0 = INTEGER: other(1)   

    UDP-MIB::udpInDatagrams.0 = Counter32: 0

    HOST-RESOURCES-MIB::hrSystemUptime.0 = Timeticks: (86219) 0:14:22.19

I am testing this on MWG 6.9 build 10927.

Please let me know if you have any ideas.

Kind regards,

Jelmar

0 Kudos
1 Solution

Accepted Solutions
asabban
Level 17

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi Jelmar,

the WW1000 are no Dell devices. They enhanced MIBs do not exist there :-/

Is there any chance to try with the WW1900? It should work without problems there.

Best,

Andre

PS: I think the MIBs also do not work on WW500. Only >= WW1100 afaik.

Nachricht geändert durch asabban on 18.07.11 08:53:43 CDT
0 Kudos
9 Replies
asabban
Level 17

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi Jelmar,

can you let me know on which kind of hardware you are running?

Best,

Andre

0 Kudos
jelz
Level 7

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi Andre,

I am currently trying this on older Cyberguard WW1000's. If I got this to work I would put this on production WW1900E's.

Kind regards,

Jelmar

0 Kudos
asabban
Level 17

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi Jelmar,

the WW1000 are no Dell devices. They enhanced MIBs do not exist there :-/

Is there any chance to try with the WW1900? It should work without problems there.

Best,

Andre

PS: I think the MIBs also do not work on WW500. Only >= WW1100 afaik.

Nachricht geändert durch asabban on 18.07.11 08:53:43 CDT
0 Kudos
McAfee Employee

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Very true! The hardware monitoring is only available on Dell and on Intel (in a different fashion) but not on the CG WW1k appliances.

best,

Michael

0 Kudos
jelz
Level 7

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi guys,

ah... I was under the impression the CG1000WW is a Dell server, but I had this checked (server is in a remote area) and indeed there is no Dell logo on it.

We have to test this on a production machine then. This will not be a problem, just a small downtime for the service restart. I'm sure this is going to work now.

Thank you!

Kind regards,

Jelmar

0 Kudos

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hello,

where can i find the guide  "Advanced hardware monitoring for Webwasher appliances"?

0 Kudos
jelz
Level 7

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Hi,

I am not sure if you can just find it. I received it from McAfee Support but do not find it through the knowledge base. Perhaps Michael has a link to this document he wrote   

0 Kudos
McAfee Employee

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Attaching the PDf, as I don't have any link handy.

This is ONLY for MWG 6.x on Dell hardware and doesn't claim to be correct or complete

best,

Michael

0 Kudos
jelz
Level 7

Re: Not able to retrieve snmp info on MWG6 from the additional MIBs

Jump to solution

Yeeh! Was just able to try it out on a WW1900E and it works great:

jelz@nagios:~ [64] # snmpwalk -v 2c -c <removed> <removed> .1.3.6.1.4.1.674.10893.1.20.130

SNMPv2-SMI::enterprises.674.10893.1.20.130.1.1.1.1 = INTEGER: 1

SNMPv2-SMI::enterprises.674.10893.1.20.130.1.1.2.1 = STRING: "PERC 6/i Integrated"

SNMPv2-SMI::enterprises.674.10893.1.20.130.1.1.3.1 = STRING: "DELL"

SNMPv2-SMI::enterprises.674.10893.1.20.130.4.1.2.1 = STRING: "Physical Disk 0:0:0"

SNMPv2-SMI::enterprises.674.10893.1.20.130.4.1.2.2 = STRING: "Physical Disk 0:0:1"

<etc><etc>

Thank you!

Jelmar

0 Kudos