cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

New VM install

Hello,

I would like to migrate 2 physical web gateways to 2 virtual machines.
Physicals are running 7.8.2.1.0 and I want to run VMs with last main release 8.2.9

What are the best practices and what could cause some conflicts, knowing that all 4 web gateways will be running at the same time, until physical ones are decommissioned. 
I remember I had problems with ?router id? which were the same as the existing running one. 

Thank you for your help

Labels (1)
3 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 4

Re: New VM install

Hi,

 

Hope you are doing well.

 

Are you also planning to upgrade your physical MWG's version as well.

 

From version 8.2.x HAproxy is being used and in previous versions mfend was being used.

 

With mfend being used and to run 2 independent clusters in same subnet   we used to configure LB ID.   With new HAproxy  you can just configure different VR ID's and accordingly configure scanner table entries.

 

Will also 4 devices be part of central management cluster?

 

 

Was my reply helpful? If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
 
 
Regards
Alok Sarda
Highlighted

Re: New VM install

Hello,

Thank you for your response.

The goal is to migrate the current physical proxy to VM with the same configuration.
We have 2 proxy lines and this one is the front.

Both lines are currently physical and running 7.8.2.1.0. The goal is to have 2 VM in 8.2.9 at the front and update physical corp line to 8.2.9 in a second time.

You mean that if I launch my new VM's in 8.2.9 in the same vlan as physical ones in 7.8.2.1.0 there won't be any problems ?

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 4

Re: New VM install

Hi,

 

Hope you are doing well.

 

With all 4 devices in same subnet with 2 MWG running HAproxy and other 2 running MWG running HA using mfend  you need to have different VR ID for both clusters  and on cluster with 7.8 version mfend is being used their you need to configure LB ID as well ((MFEND_LBID).

 

https://community.mcafee.com/t5/Web-Gateway/MWG-7-clustering-with-2-independant-Proxy-HA-clusters/td...

 

https://community.mcafee.com/t5/Enterprise-Documents/Web-Gateway-Understanding-Proxy-HA-mfend/ta-p/5...

 

 

Regards

Alok Sarda

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community