cancel
Showing results for 
Search instead for 
Did you mean: 
mmalagni
Level 9

NTLM authentication issues on SSL websites with machine out of domain - Chrome

All,

on machine outside the domain I'm experiencing issues with NTLM authentication.

NTLM pop-up correctly show up, but when you fill it with the right information on Chrome, after 2 or 3 retries it gives back an error:

ERR_CONTENT_LENGTH_MISMATCH

In the debug log I have the following error:

[2015-09-14 16:24:43.094 +02:00] [5937] NTLM (5944, x.x.x.x) URL: https://ssl.gstatic.com

[2015-09-14 16:24:43.094 +02:00] [5937] NTLM (5944, x.x.x.x) Configuration: NTLM Connection: 0x7f93bcdbe730 RR: 0x3a2dd90

[2015-09-14 16:24:43.095 +02:00] [5937] NTLM (5944, x.x.x.x) Authentication didn't return values, failure ID: 4, authentication failed: 0

[2015-09-14 16:24:43.095 +02:00] [5937] NTLM (5944, x.x.x.x) Added authentication method: Basic realm="Proxy Authentication"

[2015-09-14 16:24:43.095 +02:00] [5937] NTLM (5944, x.x.x.x) Added authentication method: NTLM

[2015-09-14 16:24:43.095 +02:00] [5905] NTLM (5945, x.x.x.x) URL: https://ssl.gstatic.com

[2015-09-14 16:24:43.095 +02:00] [5905] NTLM (5945, x.x.x.x) Configuration: NTLM Connection: 0x7f93bc5366c0 RR: 0x3e6ac70

After it it oes back in Kerberos, and back to NTLM, and then fail.

On the same page, I switch to HTTP and try an HTTP website and everything goes OK.

Any hint, would be highly appreciated.

Regards

Matteo

0 Kudos
1 Reply
McAfee Employee

Re: NTLM authentication issues on SSL websites with machine out of domain - Chrome

Hi Matteo,

It looks like the browser just isnt sending the credentials (failure ID: 4, failed: 0).

Best Regards,

Jon

0 Kudos