cancel
Showing results for 
Search instead for 
Did you mean: 
anas.ismail
Level 9

Microsoft Edge Browser authentication prompts

Hello All,

We have an issue with microsoft edge browser over Mcafee web gateway 7.6, we keep getting authentication prompts when using edge, how ever we are not getting the authentication prompts when using another browser on the same machine, this issue is happening on all machines!!

we are using NTLM authentication.

any suggestions please?

Thanks

Anas

0 Kudos
5 Replies
jameskhow
Level 7

Re: Microsoft Edge Browser authentication prompts

Hi Anas,

Can you try this to see if it works?

====================

To avoid Edge throwing up the user credentials pop up every time, add the URL of your website to the IE intranet zone. Edge shares these settings with IE.

In IE -> Settings -> Internet Options -> Security -> Local intranet -> Sites -> Advanced -> Add

====================

0 Kudos
anas.ismail
Level 9

Re: Microsoft Edge Browser authentication prompts

Thanks James for your replay,

but which website shall I add !?

this is happening to all websites

0 Kudos
jameskhow
Level 7

Re: Microsoft Edge Browser authentication prompts

Hi Anas,

Sorry I have overlooked your initial requirement is to all websites and it's not possible to put *(all) website in the intranet settings. As Microsoft Edge does not support trusted sties. Intranet sites are required for clients using Edge.

regards

James

0 Kudos
McAfee Employee

Re: Microsoft Edge Browser authentication prompts

What type of frontend authentication are you using? Authentication Server or Explicit Proxy Authentication? Both can use NTLM, AuthServer requires the MWG be added as a trusted site.

The following doc walks you through choosing the right frontend auth method if you are not familiar with them.

In my environment Edge works just fine with NTLM for both Auth Server and Explicit Proxy Auth.

Best Regards,

Jon

0 Kudos
anas.ismail
Level 9

Re: Microsoft Edge Browser authentication prompts

Thanks Jon

I was using explicit proxy authentication, I changed to authentication server and it worked fine with edge and all other browsers, but I am still confused why!?

0 Kudos