cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Microsoft Edge Browser authentication prompts

Hello All,

We have an issue with microsoft edge browser over Mcafee web gateway 7.6, we keep getting authentication prompts when using edge, how ever we are not getting the authentication prompts when using another browser on the same machine, this issue is happening on all machines!!

we are using NTLM authentication.

any suggestions please?

Thanks

Anas

5 Replies
Highlighted

Re: Microsoft Edge Browser authentication prompts

Hi Anas,

Can you try this to see if it works?

====================

To avoid Edge throwing up the user credentials pop up every time, add the URL of your website to the IE intranet zone. Edge shares these settings with IE.

In IE -> Settings -> Internet Options -> Security -> Local intranet -> Sites -> Advanced -> Add

====================

Highlighted

Re: Microsoft Edge Browser authentication prompts

Thanks James for your replay,

but which website shall I add !?

this is happening to all websites

Highlighted

Re: Microsoft Edge Browser authentication prompts

Hi Anas,

Sorry I have overlooked your initial requirement is to all websites and it's not possible to put *(all) website in the intranet settings. As Microsoft Edge does not support trusted sties. Intranet sites are required for clients using Edge.

regards

James

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 5 of 6

Re: Microsoft Edge Browser authentication prompts

What type of frontend authentication are you using? Authentication Server or Explicit Proxy Authentication? Both can use NTLM, AuthServer requires the MWG be added as a trusted site.

The following doc walks you through choosing the right frontend auth method if you are not familiar with them.

In my environment Edge works just fine with NTLM for both Auth Server and Explicit Proxy Auth.

Best Regards,

Jon

Re: Microsoft Edge Browser authentication prompts

Thanks Jon

I was using explicit proxy authentication, I changed to authentication server and it worked fine with edge and all other browsers, but I am still confused why!?

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community