cancel
Showing results for 
Search instead for 
Did you mean: 

McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

Hi, we are running two McAfee Webgateways in a cluster (Version 7.2.0.5.0). Since yesterday I see a lot of requests per second on one of them, the other one has about 40, which is normal and the first one 829, which is not normal and keeps rising. Attached you can see the output from "Top"-command, so the mwg-core process is using about "230%" CPU. Do you have an idea what could cause the problem or which logs I should check? I checked all log files available on the UI, but everything looks normal.

Top_command.JPG

Thanks,

KR
Rena

0 Kudos
1 Solution

Accepted Solutions

Re: McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

Hi, thanks for your advice! I looked up the access logs and found one IP that kept sending http requests to a nokia domain. It was Nokia Suite that tried to connect to its downloading center-because authentification failed, it just kept requesting the site... when I asked the user to reboot his notebook, the sessions went from about 830 to 50 in a second! So the application caused the high load.

Thanks again for your help.

Message was edited by: renata.petrasova on 6/23/13 3:21:44 AM CDT
0 Kudos
4 Replies
Hayton
Level 17

Re: McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

Moved from Security Awareness to Business / Email and Web Security / Web Gateway

0 Kudos
McAfee Employee

Re: McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

Hi Rena,

Perhaps a proxy loop? Are you removing the via header?

230 % is relative to the number of cores on your system. So if you have 8 cores on the system, then MWG can use up to 800%.

Best,

Jon

0 Kudos
eelsasser
Level 15

Re: McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

FYI. I really like htop better.

Image2.jpg

0 Kudos

Re: McAfee Webgateway High Amount of Requests per second / mwg-core

Jump to solution

Hi, thanks for your advice! I looked up the access logs and found one IP that kept sending http requests to a nokia domain. It was Nokia Suite that tried to connect to its downloading center-because authentification failed, it just kept requesting the site... when I asked the user to reboot his notebook, the sessions went from about 830 to 50 in a second! So the application caused the high load.

Thanks again for your help.

Message was edited by: renata.petrasova on 6/23/13 3:21:44 AM CDT
0 Kudos