cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

McAfee Web Gateway 9.2.2 transparent router mode not working

Jump to solution

I deploy McAfee Web Gateway version 9.2.2 with transparent router mode and following by installation guide.

My client point default gateway to MWG.

But MWG can't forward traffic to internet and client can't access internet.

client(10.10.10.50) ---> (10.10.10.1)MWG(192.168.1.126) ---> (192.168.1.1)Router(router set routing to 10.10.10.0/24 by 192.168.1.126)

Please help me to find this issue.

1 Solution

Accepted Solutions
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: McAfee Web Gateway 9.2.2 transparent router mode not working

Jump to solution

Hi,

 

Hope you are doing well.

 

Conducted remote session to look into this.

 

It was seen that internet connectivity from MWG was fine. IP based URL access was working fine.

 

Port redirect is configured for port 80.443 and IP Spoofing option is disabled.


So when MWG receives request for http://1.2.3.4 (eg) it was successfully redirected into rule trace and when MWG made connection towards outside source IP Address was 192.168.1.126 and connection was successful.

 

Now DNS configured in client machine/MWG is configured with global DNS 8.8.8.8 and 8.8.4.4

 

So now when client was trying to access www.googl.com, DNS error was seen. It was seen that client was initiating DNS query towards 8.8.8.8, MWG was successfully sending the packet out of outgoing interface but their was no DNS response being received. MWG will pass through this DNS traffic. Now when the DNS query request leaves MWG source IP Address is 10.10.10.50.


Router ahead should have a route for this to know where to send the response back, so it is advised to have a route added in router for 10.10.10.0/24 to send 192.168.1.126, so once response reaches MWG , MWG knows how to forward it back to client.

 

Note:- Also when IP Spoofing option was enabled IP based URL access also stopped because in this case when traffic leaves MWG source IP Address will be 10.10.10.50

 

 

Was my reply helpful? If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
 
 
Regards
Alok Sarda

 

View solution in original post

2 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 3

Re: McAfee Web Gateway 9.2.2 transparent router mode not working

Jump to solution

Hi,

 

Hope you are doing well.

 

Conducted remote session to look into this.

 

It was seen that internet connectivity from MWG was fine. IP based URL access was working fine.

 

Port redirect is configured for port 80.443 and IP Spoofing option is disabled.


So when MWG receives request for http://1.2.3.4 (eg) it was successfully redirected into rule trace and when MWG made connection towards outside source IP Address was 192.168.1.126 and connection was successful.

 

Now DNS configured in client machine/MWG is configured with global DNS 8.8.8.8 and 8.8.4.4

 

So now when client was trying to access www.googl.com, DNS error was seen. It was seen that client was initiating DNS query towards 8.8.8.8, MWG was successfully sending the packet out of outgoing interface but their was no DNS response being received. MWG will pass through this DNS traffic. Now when the DNS query request leaves MWG source IP Address is 10.10.10.50.


Router ahead should have a route for this to know where to send the response back, so it is advised to have a route added in router for 10.10.10.0/24 to send 192.168.1.126, so once response reaches MWG , MWG knows how to forward it back to client.

 

Note:- Also when IP Spoofing option was enabled IP based URL access also stopped because in this case when traffic leaves MWG source IP Address will be 10.10.10.50

 

 

Was my reply helpful? If you find this post useful, Please give it a Kudos! Also, Please don't forget to select "Accept as a solution" if this reply resolves your query!
 
 
Regards
Alok Sarda

 

View solution in original post

Highlighted

Re: McAfee Web Gateway 9.2.2 transparent router mode not working

Jump to solution
Thank you @aloksard
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community