cancel
Showing results for 
Search instead for 
Did you mean: 
doubstar
Level 8

MWGW 7.0 with webreporter 5.0

hi,

I hope someone can give me a clue how to solve the next issue please

i have installed webreporter on a server and had made the integration with mwgw 7.0  as explained in the attached doc file

after i have checkt if the logs are succesfully transfered to web report host. i see some errors:

[26/Mar/2012:16:05:10 CEST] Cannot push '/opt/mwg/log/user-defined-logs/access.log/accessxxxxxx.log' to 'http://webreporterserverip:9111/access123456789-ipv6address.xxx.log'

Detailed reason(s):

command 'curl -g -q -f  -k -s -S --connect-timeout 30 -m 300 --create-dirs  -u admin:***** -T /opt/mwg/log/user-defined-logs/access.log/access123456789.log http://webreporterip:9111/access1203261159-ipv6address.xxx.log' failed with error code 22

Error output is '<html><head><title>JBossWeb/2.0.0.GA - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 403 - </h1><HR size=\"1\" noshade=\"noshade\"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>Access to the specified resource () has been forbidden.</u></p><HR size=\"1\" noshade=\"noshade\"><h3>JBossWeb/2.0.0.GA</h3></body></html>'

SHA1Hash of password is 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'

[26/Mar/2012:16:05:12 CEST] command 'curl -g -q -f  -k -s -S --connect-timeout 30 -m 300 --create-dirs  -u administrator:******** -T /opt/mwg/log/user-defined-logs/access.log/access123456789.log http://webreporterserverip:9111/access123456789-ipv6address.xxx.log' failed with error code 22

Error output is '<html><head><title>JBossWeb/2.0.0.GA - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 403 - </h1><HR size="1" noshade="noshade"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>Access to the specified resource () has been forbidden.</u></p><HR size="1" noshade="noshade"><h3>JBossWeb/2.0.0.GA</h3></body></html>'

SHA1Hash of password is 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'

on 3/26/12 11:10:15 AM CDT
0 Kudos
7 Replies
sroering
Level 13

Re: MWGW 7.0 with webreporter 5.0

Check your log push configuration. Looks like you didn't add "/logloader/" at the end, which is important.

http://webreporterserverip:9111/logloader/

And I hope you are using Web Reporter 5.2.x (or at least 5.1.x), since 5.0.x is very old.

0 Kudos
doubstar
Level 8

Re: MWGW 7.0 with webreporter 5.0

i have tried with http://webreporterip:9111/logloader/ as well as https://webreporterip:9112/logloader/

the last one in because i have seen thats also possible to use SSL. both attempts are ending with a error.

like this one:

[27/Mar/2012:09:40:22 CEST] Cannot push '/opt/mwg/log/user-defined-logs/access.log/access1231456789.log' to 'http://webreporterip:9111/access1231456789-ipv6address.xxx.log'

Detailed reason(s):

command 'curl -g -q -f  -k -s -S --connect-timeout 30 -m 300 --create-dirs  -u admin:***** -T /opt/mwg/log/user-defined-logs/access.log/access123456789.log http://webreporterip:9111/access123456789-ipv6address.xxx.log.xxx.log' failed with error code 22

Error output is '<html><head><title>JBossWeb/2.0.0.GA - Error report</title><style><!--H1 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:22px;} H2 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:16px;} H3 {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;font-size:14px;} BODY {font-family:Tahoma,Arial,sans-serif;color:black;background-color:white;} B {font-family:Tahoma,Arial,sans-serif;color:white;background-color:#525D76;} P {font-family:Tahoma,Arial,sans-serif;background:white;color:black;font-size:12px;}A {color : black;}A.name {color : black;}HR {color : #525D76;}--></style> </head><body><h1>HTTP Status 403 - </h1><HR size=\"1\" noshade=\"noshade\"><p><b>type</b> Status report</p><p><b>message</b> <u></u></p><p><b>description</b> <u>Access to the specified resource () has been forbidden.</u></p><HR size=\"1\" noshade=\"noshade\"><h3>JBossWeb/2.0.0.GA</h3></body></html>'

SHA1Hash of password is 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx'

I see two interesting things

1st: failed with error code 22

2nd: HTTP Status 403 - Access to the specified resource () has been forbidden

does it mean that web reporter is trying to write the logs in te root dir and thats why 403 error ?

The setting on the Web Gateway side is exactly as it is giving in the Web Reporter use discription e.g.: http://ReportServerAddress:9111/logloader/

The exact Web Reporter version is: 5.2.0.05 build 1214

on 3/27/12 5:07:36 AM CDT
0 Kudos
sroering
Level 13

Re: MWGW 7.0 with webreporter 5.0

Then the usernameSmiley Tongueasswords dont' match.  Edit the log source in Web Reporter and retype the password, then do the same in the Web Gateway log push configuration.

0 Kudos
doubstar
Level 8

Re: MWGW 7.0 with webreporter 5.0

the username and pwd is 100%  correct.


I have tried to push the log via a command line with the same uid and pwd (manually typed in) and it succeeds

curl -g -q -f  -k -s -S -u adminSmiley Tongueassewordtypedinmanually -T /opt/mwg/log/user-defined-logs/access.log/access123456789.log http://webreporterip:9111/access123456789-ipv6address.xxx.log.xxx.log'

Output:

succeeds

it look like a bug in the mwgw ??

0 Kudos
fschulte
Level 10

Re: MWGW 7.0 with webreporter 5.0

In the past there have been problems with some passwords.

Try a few different passwords. E.g. first try a password without special characters, then without numbers, etc.

Which MWG version are you running on? Is it really a 7.0?

Ciao

Felix

0 Kudos
doubstar
Level 8

Re: MWGW 7.0 with webreporter 5.0

Hi Felix,  

Thank you for your reply.  


The exact mwg-version="7.1.0.6.0.12651"  The tip about using another pwd, thats a thing which i am going to try. 

ill give it a shot and update soon. 

br,

-- Said  

on 3/28/12 10:37:36 AM CDT
0 Kudos

Re: MWGW 7.0 with webreporter 5.0

Just one to watch out for guys is that the file names are consistant on the web reporter log resource and also on the gateway, this has caught me out today.

name the file in the log source the same as the file names on the web gateways found at Policy - Settings - File System Logging

0 Kudos