cancel
Showing results for 
Search instead for 
Did you mean: 
buggy49
Level 7

MWG 7 How to turn off FTP Directory Listing page?

I've disabled all rules and when I try to access ftp server via browser it appears FTP Directory Listing page. Is there any way to turn it off?

Regards

0 Kudos
9 Replies
eelsasser
Level 15

Re: MWG 7 How to turn off FTP Directory Listing page?

Have a simple rule that does this:

Rule Criteria: URL.Protocol equals "FTP"

Action: Block

0 Kudos
buggy49
Level 7

Re: MWG 7 How to turn off FTP Directory Listing page?

But I don't want to block ftp protocol. I want to see directory listing like usually comes when You go to ftp server via browser (ie Mozilla style) not the MWG 7 FTP directory listing page.

0 Kudos
eelsasser
Level 15

Re: MWG 7 How to turn off FTP Directory Listing page?

Oh, sorry. I misread the question.

The directory listing is considered a page template. It uses the Default Schema templates that all the other block pages do, and therefore editable.

However, if you remove all the formatting from the Schema, all the other block pages are subject to the same formatting. You need to create another schema for all the other block pages to have all the nice logos and formatting, and edit the default schema to look plain and simple.

0 Kudos
buggy49
Level 7

Re: MWG 7 How to turn off FTP Directory Listing page?

One more question. What triggers MWG7 FTP Directory Listing page (I've disabled all rules)?

0 Kudos
McAfee Employee

Re: MWG 7 How to turn off FTP Directory Listing page?

Hello,

The display of the page is triggered by usage of the FTP protocol.This is nothing which is bound to rules or similar, this si just usage of the protocol.

What is the problem with this page?

best,

Michael

0 Kudos
buggy49
Level 7

Re: MWG 7 How to turn off FTP Directory Listing page?

There is no problem with that page just the client asked me if that page could be turned off.

0 Kudos
McAfee Employee

Re: MWG 7 How to turn off FTP Directory Listing page?

Hi,

in this case - you can't turn it off. What basically happens is MWG gets the directory listing and renders the page. Your browser does the same normally, but as MWG sits in between it is the browser relative to the server and we can't just send the output of ls -la to the PC, so we render the page.

best,

Michael

0 Kudos
KPeter
Level 7

Re: MWG 7 How to turn off FTP Directory Listing page?

Hello!

I dont know whether it was good idea to put my problem here, or would be better to open a new discussion, but this is related exactly to this topic.

Im my case the FTP server contains files with filenames including not only english characters, and if we see it through the proxy the directory listing page displays wrong (messed up) filenames, and if we try to click on a filename, we got, that there is no file ("The requested file could not be found. ").

We can see the relevant part of the the source of the page on the directory listing:

...<a href="v%C3%A1ltoz%C3%A1s.txt">változás.txt</a>...
If we dont use proxy, the source of the page is: "...<A HREF="/..xyz../v%E1ltoz%E1s.txt">változás.txt</A>..."

So my question would be whether is it possible to stop webGW to render the ftp sites (or handle this problem correctly)?

I attached an example. On the first picture you can see the FTP Directory listing, and a problematic file (marked with red), on the second picture you can see the result if you click on the filename (and as you can see in the URL field the correct filename is displayed). 

I tried with Firefox and Internet Explorer, as well, but the result was the same.

BR,

    Peter

ps.: I know, that filenames should consist only english characters to avoid problems, but unfortunatelly now that is the case.

0 Kudos
sroering
Level 13

Re: MWG 7 How to turn off FTP Directory Listing page?

Try switching the browser encoding to UTF-8.  I was able to reproduce and fix this issue with text file names containting Japanese characters.  Also, this may seem unnecessary for me to ask, but the client PC has the necessary language support, doesn't it?

IE:

View -> Encoding -> More -> Unicode (UTF-8)

Firefox:

View -> Character Encoding -> More Encodings -> Unicode -> Unicode (UTF-8)

KPeter wrote:

Im my case the FTP server contains files with filenames including not only english characters, and if we see it through the proxy the directory listing page displays wrong (messed up) filenames, and if we try to click on a filename, we got, that there is no file ("The requested file could not be found. ").

We can see the relevant part of the the source of the page on the directory listing:

...<a href="v%C3%A1ltoz%C3%A1s.txt">változás.txt</a>...
If we dont use proxy, the source of the page is: "...<A HREF="/..xyz../v%E1ltoz%E1s.txt">változás.txt</A>..."


So my question would be whether is it possible to stop webGW to render the ftp sites (or handle this problem correctly)?



Message was edited by: sroering on 2/15/11 11:09:56 AM CST
0 Kudos