cancel
Showing results for 
Search instead for 
Did you mean: 
fire_fox
Level 7

MCP 2.2.0.225 not redirecting on windows 10 pro 1607 64bit

Hi,

I'm trying to deploy the client proxy through epo client task on windows 10 client.

Task completed with status successful but it's not working.

I configured and assigned a policy for MCP as required.

After i run "wake up agents" with "retrieve all properties ..." checked, MCP is not listed under Products.

I checked the log file under "C:\programdata\McAfee\MCP\Logs" and this is what is says:

11/03/16 : 13:34:54:253 - [ERROR] CGroupCacheManager:Smiley SurprisedpenCacheFile -  Failed to open cache file

11/03/16 : 13:34:54:253 - [ERROR] CGroupCacheManager::Initialize -  Failed opening cache file, creating new cache

11/03/16 : 13:34:54:253 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyOpgFile -  Failed to open policy file

11/03/16 : 13:34:54:253 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyOpgFile -  Failed to open policy file

11/03/16 : 13:34:54:253 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyFile -  Failed to find a policy file

11/03/16 : 13:34:54:253 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicy -  Failed to load policy file

11/03/16 : 13:34:54:253 - [ERROR] CFireCorePlugin::UpdateSystemSearchPath -  Unable to find SystemCore reg key

I tried deploying it on another client and the log file is very similar:

11/03/16 : 11:47:21:832 - [ERROR] AccessProtectionObject:Smiley FrustratedetSCMDisplayUIOptionsForService -   AccessProtectionObject:Smiley FrustratedetSCMDisplayUIOptionsForService(): Failed to SetNamedSecurityInfo error = 1115

11/03/16 : 11:47:21:832 - [ERROR] AccessProtectionObject:Smiley Very Happyisable -   AccessProtectionObject:Smiley Very Happyisable() - Failed to Set SetSCMDisplayUIOptionsForService in SCM UI, error = 1115, ignoring it

11/03/16 : 11:48:10:428 - [ERROR] mcafee::mcp::ma_app_context::log_message -  failed to open registry McAfee\Agent\, error <2>

11/03/16 : 11:48:10:443 - [ERROR] mcafee::mcp::ma_app_context::log_message -  failed to open registry McAfee\Agent\, error(2), waiting for registry key to be re-established

11/03/16 : 11:48:10:580 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyOpgFile -  Failed to open policy file

11/03/16 : 11:48:10:580 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyOpgFile -  Failed to open policy file

11/03/16 : 11:48:10:580 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicyFile -  Failed to find a policy file

11/03/16 : 11:48:10:580 - [ERROR] CWindowsRegistryPolicyDataStore::LoadPolicy -  Failed to load policy file

11/03/16 : 11:48:10:580 - [ERROR] CFireCorePlugin::UpdateSystemSearchPath -  Unable to find SystemCore reg key

Folders

C:\programdata\McAfee\MCP\Policy

C:\programdata\McAfee\MCP\Policy\Temp

are empty on both clients.

Running MCPAbout.exe shows the status:

Version Number : 2.2.0.225

Status : No policy or invalid policy applied (not redirecting)

Client proxy service is running.

I remember when I tested MCP a couple of months ago, MCP was working correctly on windows 7 pro but it refused to work on windows 10.

What could cause this problem?

Best regards,

Igor

0 Kudos