cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 

Re: Locked out of GUI

Even I need the PM. Thank you very much.

Re: Locked out of GUI

Here's the instruction, I take no responsibility if it doesn't work or makes things worse. However it worked for me.

Enable GUI again after locked due to Cluster setup
If you setup a Central Management it may happen that you find yourself locked out and unable to access any GUI on either of the nodes part of the CM. This happens because attaching the GUI to the Coordinator gets disabled. You can enable if again following these steps.

You need to have enabled SSH or alternatively you will need to plug a laptop directly into webgateway

1. Log on to box with root and password
2. run

dmidecode | grep UUIDto get the UUID of this device

3. stop MWG completely:

/etc/init.d/mwg stop

4. Change into the most recent configuration:

cd `cat /opt/mwg/storage/active_configuration`(If that does not work look into /opt/mwg/storage/active_configuration to get the path to the active configuration. Change into that folder).(Note: the command "current" should do the trick for you in newer MWG versions)- cd into the folder holding the appliance specific configuration:

cd globalcd <UUID> (replace <UUID> with the UUID you have looked up in the first step)cd cfg

5. Edit the configuration:

vi com.scur.engine.cmclusternode.configuration.xmlSearch for "enableGUI". You will find that setting set to "false". Set it to "true". Save the changes.- Now run

/opt/mwg/bin/mwg-coordinator -F "file:IN=`cat /opt/mwg/storage/active_configuration`"

6. Check the /opt/mwg/log/mwg-errors/mwg-coordinator.errors.log logfile. It should tell you

OK - enforced as folder '/opt/mwg/storage/default/xxxxxxxxxxxxxxxx'.

7. Start MWG again:

/etc/init.d/mwg start

8. Try to access the GUI again.

Re: Locked out of GUI

Thank you for your answer, but the solution does not work.

The setting was already "true"  in both nodes...

This problem has occurred with the upgrade from version 7.2.0 to 7.3.0.

Any other suggestions?

thanks in advance.

Re: Locked out of GUI

The errors are:

[FATAL] Could not start Konfigurator:

and

[FATAL] Error parsing type ops file:

fschulte
Level 10
Report Inappropriate Content
Message 15 of 17

Re: Locked out of GUI

Its probably best to contact the official support, General.

klara
Level 10
Report Inappropriate Content
Message 16 of 17

Re: Locked out of GUI

Hi, I'm Keila

I have the same problem, please can you be more specific with the instruction, I don't know nothing about linux and it's not working for me.

Thanks a lot for your support.

giulio
Level 9
Report Inappropriate Content
Message 17 of 17

Re: Locked out of GUI

thanks, it worked perfectly on me.

Maybe it is better to disable the uncheck on that box 🙂

 

Bye

Giuliano

Tags (1)
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community