cancel
Showing results for 
Search instead for 
Did you mean: 
yans112
Level 7

Latency

Hello,

Could someone, please help me upon, How to check the latency in Mcafee Web Gateways?

Thanks in advance.

Regards,

Yans.

0 Kudos
5 Replies
feickholt
Level 10

Re: Latency

You can easily verify the latency using the dashboard.

Look at performance information. I think "Used by Rule Engine" is the time you are looking for.

You can also use a rule trace and analyse the timestamps for each rule to find out if there is a bottle neck configured within your policy

Frank

0 Kudos
asabban
Level 17

Re: Latency

Please note that "Used by Rule Engine" does not include latency not caused by MWG, such as time it took to resolve DNS and/or fetch the data from the server. So if the time MWG takes in the rule engine looks OK the problem might be related to the environment.

Rule Engine Traces can also give some hints on this. Note that the GUI only displays "Durations", while the plain XML file logs  exactly at what timestamp which rule was entered. If the GUI view does not give a clue try looking at the timestamps of the rules. If you see delays between processing the last rule in the request cycle and entering the response cycle this is caused by network/DNS issues most of the times.

Best,

Andre

0 Kudos
yans112
Level 7

Re: Latency

General Per.PNGHTTP Traffic.PNG

Hello Feickholt/Asabban,

 

Thanks for your informative replies.

I am new to this MWG. However, I have
checked under Performance Information tab. I am able to check the DNS lookup,
Connection established time & Rule engine processing duration.  As per the above ref screenshot, Could you
please let me know the latency time for the attached screenshot.

  

And also please let me know, where can I found the XML file logs details. Is it under the Alerts, Informational logs
or else.

Thanks in advance.

Regards,

Yans.

0 Kudos
feickholt
Level 10

Re: Latency

you may tick dns lookup and connect to server, then you will receive a graph with the time the rule engine consumes.

In my first look I would asume the link to the server or the server you want to connect to is heavy loaded.  (up to 7sec for a single connect to a server... I would not accept such values)

0 Kudos
yans112
Level 7

Re: Latency

I don't think these values are appropriate. In Sophos WG and Ironport We can see the pre-defined Latency report. In the MWG, there is no pre-defined option to look onto it.

However, thanks for your inputs.

0 Kudos