cancel
Showing results for 
Search instead for 
Did you mean: 
wyrm
Level 9

Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

I noticed today that Kerberos authentication is no longer working on any of my MWG appliances.  The ruleset has not changed.  I had a lot of stuff going on this week so I'm not sure if it broke before or after I upgraded from 7.7.2.6 to 7.7.2.7.  Can anyone here confirm if Kerberos is working for their appliances after upgrading to 7.7.2.7?

0 Kudos
1 Solution

Accepted Solutions
wyrm
Level 9

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Ugh... I'm so annoyed.  Keytab version mismatch.  My server team made a change on the AD side... I'm not sure why, because I didn't ask them to update the keytab.

0 Kudos
7 Replies
McAfee Employee

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

I'll check on my end, is there anything in the mwg-core error logs?

0 Kudos
wyrm
Level 9

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Log just shows this repeating over and over:

[2017-12-04 06:43:35.293 -05:00] [Auth] [KerberosAuthentication] 'gss_accept_sec_context' 'GSS_MECH' error : 'Wrong principal in request'

[2017-12-04 06:43:45.335 -05:00] [Auth] [KerberosAuthentication] 'gss_accept_sec_context' 'GSS_API' error : 'Unspecified GSS failure. Minor code may provide more information'

0 Kudos
wyrm
Level 9

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

I may have found the issue... it looks like something is wrong with my keytab file... klist command isn't showing the correct information.  I'm not sure why this happened all of a sudden.  We brought some new appliances into the cluster, so I'm not sure if that messed something up. 

0 Kudos
McAfee Employee

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Hi wyrm,

Adding new nodes shouldnt hurt the keytab. Were you able to re-upload the keytab and get it working again?

I had tested the upgrade from 7.7.2.6 to 7.7.2.7, and didnt see any issues (I took snapshots to doublecheck things).

Best Regards,

Jon

0 Kudos
wyrm
Level 9

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Ugh... I'm so annoyed.  Keytab version mismatch.  My server team made a change on the AD side... I'm not sure why, because I didn't ask them to update the keytab.

0 Kudos
McAfee Employee

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Ouch.

If you are going to need it regenerated, give this tool looksie:

0 Kudos
wyrm
Level 9

Re: Kerberos Authentication failing after 7.7.2.7 update?

Jump to solution

Thanks, I used the 3-headed dog first time around.  I'm new to this product... I have been building and testing over the past 1-2 months and haven't started piloting to end users yet.  I'm glad this issue came up before it went into my production environment.  I'm REALLY glad those keytab files keep the version/revision number...  otherwise I would not have been able to prove my server team was the cause.

0 Kudos