cancel
Showing results for 
Search instead for 
Did you mean: 
itagsupport
Level 9

Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hi all

Since upgrading two MWG 7.x cluster environments from 7.3.2.3.0 to 7.3.2.6 we see the following error messages in mwg-core.error.log from time to time but we can't find the cause for it:

[2014-03-03 15:34:12.164 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-03 15:34:12.175 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-03 15:34:12.175 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

Our customer runs 2 clusters (test and prod) with 2 members each. The clusters seem to work fine with the new release.

However, maybe there is a configuration problem in the rules somewhere but we don't have any idea where to start.

Doing a change in the Rules configuration can be applied/activated without any problem.

The Dashboard does not show any 'Warning' or 'Error' Alerts for both members.

Thanks for any good input.

Regards,

Tom E.

0 Kudos
1 Solution

Accepted Solutions
itagsupport
Level 9

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello,

we filed a ticket and got this answer:

> The error message is caused for every bad request the client makes.

> For every bad request the rule engine is not called in request nor in response cycle.

> For such a request rule engine is only called in logging cycle, which is causing the problem.

> There is no work around for this, however the message will be fixed in 7.3.2.7.

In other words: You can safely ignore this message...

Regards

Andreas

0 Kudos
7 Replies
sthe
Level 9

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello

Same problem since upgrade from 7.3.2.4 to 7.3.2.6

We are running a single node configuration. Physical Appliance WBG-5000-B

As you can see in our log the problem seems to appear from time to time

[2014-03-04 02:40:38.799 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 02:40:38.799 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 02:40:38.799 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 02:40:39.501 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 02:40:39.501 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 02:40:39.501 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 02:40:39.579 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 02:40:39.579 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 02:40:39.579 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 02:40:39.625 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 02:40:39.626 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 02:40:39.626 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 02:40:39.703 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 02:40:39.704 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 02:40:39.704 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 06:40:13.997 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 06:40:13.997 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 06:40:13.997 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 06:40:14.730 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 06:40:14.730 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 06:40:14.730 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 06:40:14.793 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 06:40:14.793 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 06:40:14.793 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 06:40:14.855 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 06:40:14.855 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-04 06:40:14.855 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

[2014-03-04 06:40:14.933 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-04 06:40:14.933 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

I would also appreciate any helpful comment

0 Kudos
asabban
Level 17

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello,

I looked at our bug tracking system but I wasn't able to find any details what may cause these problems or how to solve them. At least it sounds strange... I strongly recommend to file a ticket with tech support (unless not already done) to have them look at that issue and if required escalate to engineering.

Best,

Andre

0 Kudos
sthe
Level 9

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello Andre

Thank you for your reply. I am sure itagsupport will take care of it as we are a customer of them

Best

Stefan

0 Kudos
maitane
Level 7

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello,

I have the same problem. I upgraded the appliances to 7.3.2.6.0 and now I have this errors.

[2014-03-17 08:29:52.514 +01:00] [Core] [CannotExecuteRules] 'Rule Engine: Execute': Cannot execute rules, no rules available (maybe parsing of rules failed?).

[2014-03-17 08:29:52.514 +01:00] [Core] [InternalError] 'Error while executing state: Unexpected rule engine error'

[2014-03-17 08:29:52.514 +01:00] [Core] [ErrorDuringOperation] 'CHost::IFProcessTransaction': Error while 'executing' the 'FlowManager'. Reason: 'internal error'.

Does anybody know what is happend?

Regards

0 Kudos
asabban
Level 17

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

I wanted to say the same thing, but Andreas was quicker. Thank you :-)

Best,

Andre

Nachricht geändert durch asabban on 17.03.14 11:13:35 MEZ
0 Kudos
itagsupport
Level 9

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello,

we filed a ticket and got this answer:

> The error message is caused for every bad request the client makes.

> For every bad request the rule engine is not called in request nor in response cycle.

> For such a request rule engine is only called in logging cycle, which is causing the problem.

> There is no work around for this, however the message will be fixed in 7.3.2.7.

In other words: You can safely ignore this message...

Regards

Andreas

0 Kudos
maitane
Level 7

Re: Errors in mwg-core.errors.log after upgrading MWG Cluster from 7.3.2.3.0 to 7.3.2.6

Jump to solution

Hello,

Thank you very much both for your quick answer.

0 Kudos