cancel
Showing results for 
Search instead for 
Did you mean: 
iburke
Level 7

Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

I have a McAfee Web Gateway appliance and when I have users going through the web gateway proxy they are unable to download itunes.  Basically, you go to download itunes and it acts as if it worked and goes to a website saying "thank you for downloading itunes."   But nothing has been downloaded and there is no prompting for saving the exe, etc.  

Can someone provide me some direction on how to unblock this download or troubleshoot this issue.  I've also had issues with Akamai download program for Microsoft downloads and having to use the browser to download instead.  Usually when a site is blocked, I'll get some sort of block page but in this instance nothing happens.

1 Solution

Accepted Solutions
alexn
Level 14

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

http://appldnld.apple.com  whitlist this complete url as mentioned by Cscoup8,plus 4 other excusions.

0 Kudos
8 Replies
cscoup8
Level 9

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

There may be a better way than this, but for troubleshooting purposes does it work if you exclude the following 4 from the URL domain that the itunes installer is actually downloaded from (appldnld.apple.com)

  • progress page
  • data trickling
  • anti-malware scanning
  • opener
0 Kudos
skloepping
Level 9

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

Hi iburke,

you can also enable the rule tracing setting and see where your request might stuck.

Also cscoup8 is right, that are the 4 possible reason. also keep in mind to look at your download media blocklist, also it have to had a blockpage if this rule was triggered. you may want to global whitelist *.apple.com for testing purpose for a workarounf.

BR

0 Kudos
iburke
Level 7

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

Thanks for the responses.  I am not familiar with how rule tracing works.  I see the rule tracing entry in troubleshooting but do not know how to activate it.  If I globally whitelist the download url, I am able to download the file. 

0 Kudos
alexn
Level 14

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

http://appldnld.apple.com  whitlist this complete url as mentioned by Cscoup8,plus 4 other excusions.

0 Kudos
btlyric
Level 12

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

To use rule tracing, create a rule at the top of the rule set which will enable the rule tracing engine.

For example:

Debug -> Enable Rule Tracing

     Criteria = Client.IP equals a.b.c.d (where a.b.c.d is the system you are testing from)    

     Action = Continue

     Events = Enable Rule Tracing Engine

This will create log files that illustrate every rule that the connection has traversed and what the result of the rule was -- true or false.

0 Kudos
asabban
Level 17

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

Note: Do yourself a favor and disable the rule engine tracing after you gathered the information you were looking for. Otherwise MWG may write tons of data which will fill your harddrive and impact performance.

Best,

Andre

iburke
Level 7

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

Thanks for the info eveyone. 

0 Kudos
mihai
Level 7

Re: Download of itunes won't work with web gateway 7.3 proxy....help to unblock

Jump to solution

Hello guys,

I am having the same problem with iTunes download. I've found out the rule that is blocking and I am not too happy to disable it:

IF Antimalware.Infected<Gateway Antimalware> equals TRUE --> BLOCK<Virus Found>

If I disable the rule, the pop-up for downloading the file is shown and everything works fine...as soon as I enable it, the pop-up doesn't appear anymore even if no error is displayed....

0 Kudos