cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Level 8
Report Inappropriate Content
Message 1 of 6

Disable 9121\tcp port on CSR

Hello,

 

A security scan detect some vulnerabilities on tcp/9121 port of CSR version 2.6.0.

What's the recommended procedure for disable this port?

 

Best regards!

5 Replies
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 6

Re: Disable 9121\tcp port on CSR

You could try this.  I have not tried this and make no guarantees...

 

Go to X:\Program Files\\McAfee\Content Security Reporter\reporter\conf and make a subdirectory called "resources" then a subdirectory under "resources" called "system" (so in the end you should have  \McAfee\Content Security Reporter\reporter\conf\resources\system

Copy "X:\Program Files\McAfee\Content Security Reporter\reporter\conf\examples\resources\system \server.properties" to X:\Program Files\McAfee\Content Security Reporter\reporter\conf\resources\system

You could try commenting out the line FtpServerPort 9121 and restarting CSR to see if that resolves the issue.

 

(this assumes the install path is X:\Program Files\McAfee\Content Security Reporter\ for your installation)

Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 6

Re: Disable 9121\tcp port on CSR

*** update ***

 

The previous method didn't work, but when I set the port at 9112, it looks like it only allowed https connections, not FTP to come through on that port.  

This might be worth testing out in your own environment 

Highlighted
Level 8
Report Inappropriate Content
Message 4 of 6

Re: Disable 9121\tcp port on CSR

Hello AaronT,

Thanks for your help.

I need to disable this function, because if I just change this tcp port I believe the system will keep vulnerable.

What do you think?
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 5 of 6

Re: Disable 9121\tcp port on CSR

When I did this, 9121 didn't respond anymore, and 9112 only responded to HTTPS.  Will that not suffice for "disabling" the function?  As long as logs still flow after making the change and you can do a scan, it might be worth a try, no?

Highlighted
Level 8
Report Inappropriate Content
Message 6 of 6

Re: Disable 9121\tcp port on CSR

Thanks a lot for your help AaronT, I will try.

 

Best regards!

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community