cancel
Showing results for 
Search instead for 
Did you mean: 
wollerd
Level 7

Console port is not configured to timeout

Jump to solution

As part of our McAfee Web Gateway accreditation (version 7.1.0.5.0 (12054)),our console port must be configured to timeout in 10 minutes.  I have been unable to find such a setting.  Any assistance would be greatly appreciated.

Regards,

David

0 Kudos
1 Solution

Accepted Solutions
dstraube
Level 11

Re: Console port is not configured to timeout

Jump to solution

Hello David,

you can configure a timeout for the console access, but you cannot do it directly from the MWG GUI. You need to login via console and change the shell script.

This command (executed as root from the console or via SSH) should do the trick:

echo "export TMOUT=300" >> /etc/bashrc

This will set the timeout to 300 seconds. You can change the value of cause to anything that suits your needs.

If you want to make this setting readonly, so that the user can not extend or disable the idle time you need to issue another command:

echo "readonly TMOUT" >> /etc/bashrc

The changes will be active for the next session.

Regards,

Dirk

0 Kudos
3 Replies
dstraube
Level 11

Re: Console port is not configured to timeout

Jump to solution

Hello David,

you can configure a timeout for the console access, but you cannot do it directly from the MWG GUI. You need to login via console and change the shell script.

This command (executed as root from the console or via SSH) should do the trick:

echo "export TMOUT=300" >> /etc/bashrc

This will set the timeout to 300 seconds. You can change the value of cause to anything that suits your needs.

If you want to make this setting readonly, so that the user can not extend or disable the idle time you need to issue another command:

echo "readonly TMOUT" >> /etc/bashrc

The changes will be active for the next session.

Regards,

Dirk

0 Kudos
wollerd
Level 7

Re: Console port is not configured to timeout

Jump to solution

Dirk,

Thank you for your response.  We'll give that a try and report back.

David

0 Kudos
wollerd
Level 7

Re: Console port is not configured to timeout

Jump to solution

Thank you Dirk,

This work flawlessly.  I've added these instructions to my repertoire!

0 Kudos