cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
mtmy-zul
Level 9
Report Inappropriate Content
Message 1 of 4

Cannot use MWG 9.2.4 as gateway in windows 10 Vmware

Hi, 

After setup MWG 9.2.4 as gateway ip, windows 10 vmware unable to connect to internet. I used google DNS (8.8.8.8). MWG setup as transparent router mode.

mwg-no internet.PNG

3 Replies
asabban
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 4

Re: Cannot use MWG 9.2.4 as gateway in windows 10 Vmware

Hello,

sorry but there is no information that could help troubleshoot the issue. For packets MWG does not intercept (by default TCP port 80 and 443) MWG will just forward the packets to the next hop.

It looks like you are unable to get out to 8.8.8.8. Either the routing does not work properly or there is a firewall in between that drops the packets.

I recommend to make a packet capture on the MWG and see what happens.

If this is sort of a test network that has been spun up in the existing network this is a typical error:

Client (10.0.0.2) ---> (10.0.0.1) MWG as Default Gateway (192.168.0.100) ---> 192.168.0.1 (Default Gateway) ---> Internet

If you know send a packet to 8.8.8.8 the client will send a packet 

From: 10.0.0.2
To: 8.8.8.8

MWG will take this packet and forward it to the Default Gateway. The Default Gateway will forward it to the Internet, likely doing NAT.

Now a response is coming back to the Default Gateway:

From: 8.8.8.8
To: 10.0.0.2

The Default Gateway does not know where 10.0.0.2 is, unless the routing is setup properly. It needs to be told that 192.168.0.100 (MWG) can route the packets for 10.0.0.2 by adding a route.

Anyway, this is just a guess du to lack of data. Maybe you can share some details that help troubleshooting or file a ticket with support.

Andre

mtmy-zul
Level 9
Report Inappropriate Content
Message 3 of 4

Re: Cannot use MWG 9.2.4 as gateway in windows 10 Vmware

Hi,

The client PC IP is x.x.3.115, our default gateway is x.x.3.1 and MWG is x.x.3.77. They are all in the same network. use default gateway has no prob to go internet. After doing some changes in MWG > Configuration > Proxies (HTTP(S), FTP, SOCKS...) by your tech remotely (solving different issue previously) , client pc unable to use MWG as a gateway anymore.

asabban
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 4

Re: Cannot use MWG 9.2.4 as gateway in windows 10 Vmware

Hello,

was this setup working before and is no longer working after changes were made? If so, what changes were made?

It might be the best to file a ticket with Support, so we have a chance to collect and review some data to find out what happens.

Andre

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community