cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted

Cannot get through authentication on workstation that is not domain-joined

Hi,

I have problems with MWG to work with workstation that are not domain-joined. When I went on internet, the authentication box came up as expected. However, after I had entered valid user credentials, the browser prompted right away asking for credential again. I just cannot get through authentication. I even tested with all the rules deleted but the authencation ruleset. Same issue on IE, Chrome and Firefox.

If the workstation is domain-joined, it can do integrated authentication without prompting. Authentication.Authencate<NTLM> returns true. Same on IE, Chrome and Firefox.

The MWG devices have joined domain and the user credentials are authenticated OK. I am using the authentication rule from the library with the original user database swapped to NTLM. 

Engine setting as below:

auth engine.PNG

 I tried both with and without 'Send domain and machine ..' but it is the same.

Can anyone help?

Thanks.

LL

5 Replies
Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 2 of 6

Re: Cannot get through authentication on workstation that is not domain-joined

Hi,

Hope you are doing well.

You can try below once for non domain clients:-

 

If all clients can do NTLM than Try NTLM is better.

 

IF Authentication.Authenticate<NTLM> is false and Authentication.Failed is false

               Authenticate.

 

This way non-domain members try to authenticate silently and their names are logged even authentication fails.

 

Regards

Alok Sarda

Highlighted

Re: Cannot get through authentication on workstation that is not domain-joined

Hi Alok,

Thanks for your help. It is working now.

Thanks.

Regards,

LL

 

Highlighted
McAfee Employee
McAfee Employee
Report Inappropriate Content
Message 4 of 6

Re: Cannot get through authentication on workstation that is not domain-joined

Hi,

Hope you are doing well.

Glad to hear that it is working after making suggested configuration.

 

Regards

Alok Sarda

Highlighted

Re: Cannot get through authentication on workstation that is not domain-joined

Thanks. It's working now.

gmail sign up

Tags (1)
Highlighted

Re: Cannot get through authentication on workstation that is not domain-joined

Thank you very much now totally working fine. rediffmail login

You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community