cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 1 of 3

CLI timeout setting

Jump to solution

We recently upgraded from 7.8.x to 8.2.x and it looks like when we access the CLI via ssh, the timeout is 2 minutes or less.  This is very inconvenient when trying to do things from the command-line.

Does anyone know where this setting can be changed to be more user friendly?

 

1 Solution

Accepted Solutions
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 3

Re: CLI timeout setting

Jump to solution

you can set keep-alive setting to prevent timeout on the client and/or on the server side:

client side (putty): in the putty settings (see attached screenshot) set "seconds between keepalives"  to 10. This will keep your setting virtually forever (or until firewall close the session).

SSH keepalivesSSH keepalives

server side (need to be done on each MWG): configuration > files > sshd_config, add "ClientAliveInterval 120". Together with ClientAliveCountMax (default 3), this will set the timeout to 6 minutes. Increase these settings to desired values.

View solution in original post

2 Replies
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 2 of 3

Re: CLI timeout setting

Jump to solution

you can set keep-alive setting to prevent timeout on the client and/or on the server side:

client side (putty): in the putty settings (see attached screenshot) set "seconds between keepalives"  to 10. This will keep your setting virtually forever (or until firewall close the session).

SSH keepalivesSSH keepalives

server side (need to be done on each MWG): configuration > files > sshd_config, add "ClientAliveInterval 120". Together with ClientAliveCountMax (default 3), this will set the timeout to 6 minutes. Increase these settings to desired values.

View solution in original post

Highlighted
Reliable Contributor
Reliable Contributor
Report Inappropriate Content
Message 3 of 3

Re: CLI timeout setting

Jump to solution
Thanks. That appears to have solved our problem
You Deserve an Award
Don't forget, when your helpful posts earn a kudos or get accepted as a solution you can unlock perks and badges. Those aren't the only badges, either. How many can you collect? Click here to learn more.

Community Help Hub

    New to the forums or need help finding your way around the forums? There's a whole hub of community resources to help you.

  • Find Forum FAQs
  • Learn How to Earn Badges
  • Ask for Help
Go to Community Help

Join the Community

    Thousands of customers use the McAfee Community for peer-to-peer and expert product support. Enjoy these benefits with a free membership:

  • Get helpful solutions from McAfee experts.
  • Stay connected to product conversations that matter to you.
  • Participate in product groups led by McAfee employees.
Join the Community
Join the Community